summaryrefslogtreecommitdiff
path: root/RepositoryExternal.mk
AgeCommit message (Collapse)AuthorFilesLines
13 daysexternal: bundle box2dSarper Akdemir1-0/+35
Bundled box2d with the build system of LO as a static library. If --with-system-box2d was specified checks for instance box2d in the system, defines SYSTEM_BOX2D and uses the library from the system. Change-Id: Ifb05912f2acaff273b25abebafc5af1cac3afec4 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/94103 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
2020-05-04Missing gengal vclplug dependencies for macOS and WindowsStephan Bergmann1-0/+2
Building e.g. Gallery_backgrounds from scratch failed there with no suitable windowing system found, exiting. Change-Id: Icf2dd26441554e573914f371d0d5eb21e99f5f0f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93429 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2020-04-06lxml: try to remove some quirky PYPATH stuffMichael Stahl1-1/+0
In RepositoryExternal.mk, a system python automatically gets $PYPATH added to $PYTHONPATH, but the internal one does not - this doesn't make sense. Try to remove it for system-case by fixing the one case that relies on it and for which it was introduced in commit 84ef6d82546b044990f4efd57e51e29c6c6565c8 to directly extend $PYTHONPATH instead, which ought to work as long as it's not evaluated at global scope and thereby avoids affecting all python invocations. Change-Id: I4534f2be92b850dc01193cb1bb2e0a299a5152be Reviewed-on: https://gerrit.libreoffice.org/c/core/+/91748 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@cib.de>
2020-03-18implement text rendering using directly Skia (X11)Luboš Luňák1-0/+1
The Cairo-based way reuses code that is used for OpenGL, but it's needlessly complicated, given that Skia itself is capable of text rendering as well. This requires a small patch for Skia so that it uses the FcPattern* we use for selecting a font. The rendering with this commit is usable, but visually the result is noticeably different, so this will need tweaks to the font rendering (TBD). Change-Id: I058c282307106c929ccc9faa7b2bddfabf0f0a2c Reviewed-on: https://gerrit.libreoffice.org/c/core/+/90580 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
2020-02-27tdf#130725: use strtod by David M. Gay to make sure we get the nearestMike Kaganski1-0/+17
... representation of given decimal. Use dtoa.c from https://www.netlib.org/fp/dtoa.c to build a custom static library that doesn't use current locale (unlike strtod from stdlib.h). This is the implementation used by e.g. python and nss (search for "dtoa.c" under UnpackedTarball). To avoid name clash with the standard strtod, rename the function to strtod_nolocale. Size of buffer on stack in ImpSvNumberInputScan::StringToDouble is 256 characters. Logging function usage in make check, of ~124 600 invocations, the longest string was 14 characters, average being 2.1 characters. So heap allocation is unlikely in scenarios with intensive function usage. After std::from_chars is available in baseline compilers, external library can be dropped, and call to strtod_nolocale replaced with the standard function. The artifact at https://dev-www.libreoffice.org/src/dtoa-20180411.tgz is created with mkdir dtoa && mkdir dtoa/src && wget https://www.netlib.org/fp/dtoa.c -O dtoa/src/dtoa.c && \ printf 'd8bab255476f39ea495c8c8ed164f9077da926e6ca7afb9ad3c56d337c4484fe dtoa/src/dtoa.c' | sha256sum -c && \ tar -c --owner=0 --group=0 --mode=go=r,u=rw --mtime='Wed, 11 Apr 2018 15:59:39 GMT' dtoa/src/dtoa.c | gzip -n > dtoa-20180411.tgz && \ printf '0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4 dtoa-20180411.tgz' | sha256sum -c (where the date "Wed, 11 Apr 2018 15:59:39 GMT" is from `wget -S https://www.netlib.org/fp/dtoa.c` "Last-Modified: Wed, 11 Apr 2018 15:59:39 GMT" header). Change-Id: Ia61b7678e257c4bc1ff193f3f856d611aa5c1a21 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/88854 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
2020-02-06always define GLM_FORCE_CTOR_INIT when using glmCaolán McNamara1-1/+10
Change-Id: I2a4ed756c6d18937d2c720243652df7a2d629959 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/88121 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
2020-01-23pdfium: don't patch out the COMPONENT_BUILD check, define itMiklos Vajna1-0/+1
So next time we update, no need to adapt a failing patch. Change-Id: I785f16047d1decbf922177fdde4bc6aad7cfebfc Reviewed-on: https://gerrit.libreoffice.org/c/core/+/87215 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
2020-01-09python3: bundle libffi for GNU/Linux buildsMichael Stahl1-0/+6
CPython commit f40d4ddff3c800b3c956a5e8820aabe3aa87cddd "Closes #27979: Remove bundled copy of libffi" causes a bit of a problem because it turns out that libffi isn't all that stable; there's libffi.so.5 on CentOS 6, libffi.so.6 on CentOS 7 and libffi.so.7 on lo_daily_update_gandalf tinderbox. So we have to bundle it in LO; it's only used on GNU/Linux currently. CPython commit 32119e10b792ad7ee4e5f951a2d89ddbaf111cc5 "bpo-35947: Update Windows to the current version of libffi (GH-11797)" also removes the libffi for MSVC, so in a future python upgrade we will have to build libffi for MSVC too. The libffi fork for MacOSX is still in CPython git master. (regression from b10be5d48433076f0b7238d818020f708553e114) Change-Id: Ibc20cf8cd3614cf9941b6970662bd930496776b2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/86493 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@cib.de>
2019-11-27make SkiaSalGraphicsImpl use GPU-backed SkSurface also for offscreenLuboš Luňák1-0/+1
Skia's sk_app::WindowContext can create GPU-backed SkSurface only for windows, but we also use virtual devices that are not windows. Fortunately, SkSurface can be created GPU-backed from GrContext* and sk_gpu_test::GrContextFactory seems to provide it easily. It is not completely clear to me what the rules are on mixing SkSurface's with different GrContext* (see the comment in SkiaSalGraphicsImpl::copyBits()), but it seems to work fine. Change-Id: I8110b67c41ab092e0c4b6a0973d6bed8a408c4c1
2019-11-27add SAL log group vcl.skia for tracing Skia usageLuboš Luňák1-0/+1
Change-Id: Ife21bbe0b86c3edd20e657da09c6e218fa4fced3
2019-11-27skia: implement invert operationTomaž Vajngerl1-0/+1
Change-Id: I248518283ee6a4604bc45f36f2af3804a15f5652
2019-11-27use the same config file for skia build and using itLuboš Luňák1-5/+10
So that the setup is consistent. Change-Id: Ia113c7bf79036e3ec7585263ed70da68e461fbac
2019-11-27initial empty Skia VCL implementationLuboš Luňák1-0/+1
This mostly duplicates OpenGL cases. Pretty much all implementation methods are empty. Change-Id: I333506f56dcc46c3e9405fe8194c172de17c54fd
2019-11-27initial build of the Skia libraryLuboš Luňák1-0/+14
Not quite complete yet, missing e.g. Vulkan sources, and the setup is not completely correct either. Change-Id: I2283bf12f0d226ff8a34554deae5a7bd69045971
2019-10-22Missing test dependencyStephan Bergmann1-1/+1
Noticed when executing CppunitTest_sccomp_solver that it apparently depended on ExternalProject_lpsolve but not on ExternalPackage_lpsolve. (LpSolverTest::testLpSolver in sccomp/qa/unit/solver.cxx instantiates UNO service com.sun.star.comp.Calc.LpsolveSolver in Library_solver, which uses lpsolve as an external.) Thanks to mst for showing me the right place to fix. Change-Id: I71a1c3552473ff6fea616805eea1fb68143d255b Reviewed-on: https://gerrit.libreoffice.org/81133 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2019-10-01gbuild: treat $(DCONF_CFLAGS) as includes, not definesMichael Weghorn1-1/+5
Since that variable holds the relevant includes, using 'gb_LinkTarget_set_include' makes sure that those flags end up in the correct section, e.g. when generating IDE integration using 'gbuild-to-ide', and thus prevents issues like that described in 4aa60490622cc10f8d3a31489c62a5622d240c83 ("gbuild: treat $({QT,KF}5_CFLAGS) as cxxflags, not defines"). (Value of 'DCONF_CFLAGS' variable on Debian testing with 'libdconf-dev' 0.34.0-1 is: DCONF_CFLAGS=-pthread -I/usr/include/dconf -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include ) Change-Id: I74c5194d88838bffa2b8515372266336627f235c Reviewed-on: https://gerrit.libreoffice.org/79874 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
2019-09-30drop gtk2 supportCaolán McNamara1-28/+0
Change-Id: Ie838cabfecfef7e3225c1555536d5c9cf3b43f15 Reviewed-on: https://gerrit.libreoffice.org/77405 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
2019-08-15Switch mdds to 1.5.0 and liborcus to 0.15.0.Kohei Yoshida1-2/+2
Change-Id: Ibff9a5e0f0771e4cf12b4dc3985661a01195e265 Reviewed-on: https://gerrit.libreoffice.org/77482 Tested-by: Jenkins Reviewed-by: Kohei Yoshida <kohei@libreoffice.org>
2019-07-25external qrcodegen looks under qrcodegenCaolán McNamara1-2/+3
Change-Id: I01f06c30a52f5e4cdb5b4b6304072aa0f3a63aa8 Reviewed-on: https://gerrit.libreoffice.org/76291 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
2019-07-25QRCode Dialog Box featureShubham Goyal1-1/+1
The patch handles the created QR code as a Customized Shape (Graphic Object) Change-Id: I1cee6f0e7fac585de880a9ac34e3bc441a4b7390 Reviewed-on: https://gerrit.libreoffice.org/74167 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com> Reviewed-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
2019-07-21tdf#125922 rename kde5 to kf5 + plasma5Jan-Marek Glogowski1-5/+5
Just as the gtk3 plugin isn't named GNOME, rename kde5 to kf5, as it is based on the KDE frameworks 5 libraries. This also includes: * a convenience alias to load the kf5 VCL plugin in case someone requests the kde5 plugin. * keep convenience kde5 configure switch, but warn about it * rename detected desktop from kde5 to plasma5 Change-Id: I6764a05b81a5edbf284484c234fee2649aacf735 Reviewed-on: https://gerrit.libreoffice.org/75313 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
2019-07-02bundle external: qrcodegenShubham Goyal1-0/+34
The bundle helps to generate QR code in LO. Change-Id: Iaa9225a72d15806c929d30951cefd3f3fee8960e Reviewed-on: https://gerrit.libreoffice.org/73302 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
2019-06-13Drop '-Wno-shadow' previously set for qt5/kde5Michael Weghorn1-12/+0
The flag has been introduced with commit 9335945c7cb215f387ed1444e28533fac437c6e8 ("KF5 initial VCL plugin") and was presumably just copy-pasted in commit 4d78cf97d7b1629556df68fc461922fda930d9ec. The flag should no longer be necessary now; the only issue showing up after removing the flag was fixed. Change-Id: I65fe4d12bdf7d5888b75f8a5743bab6979a63295 Reviewed-on: https://gerrit.libreoffice.org/73892 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
2019-06-08gbuild: treat $({QT,KF}5_CFLAGS) as cxxflags, not definesMichael Weghorn1-1/+1
Treat all of QT5_CFLAGS, QT5_GLIB_CFLAGS and KF5_CFLAGS as C++ flags, since those contain C++ flags in the first place. Therefore, set them using 'gb_Library_add_cxxflags', not 'gb_Library_add_defs'. (Strictly speaking, those variables contain includes as well, but handling that properly would require splitting this up further, either in 'configure.ac' or see e.g. how it's done in 'RepositoryExternal.mk'.) This also prevents the values of those variables from ending up in the wrong section in IDE integration generated by gbuild-to-ide. Handling them as includes previously resulted e.g. in 'vcl/vcl.pro' (generated by 'make qtcreator-ide-integration') containing DEFINES += BOOST_ALL_NO_LIB \ ... \ VCLPLUG_GTK3_KDE5_IMPLEMENTATION -isystem /usr/include//KF5 -isystem /usr/include//KF5/KCoreAddons [...] and Qt Creator would show a (rather unhelpful) warning like the following when opening a header file inside 'vcl/inc/': > Warning: The code model could not parse an included file, > which might lead to incorrect code completion and highlighting, > for, example. > > 4:9: error: macro name must be an identifier Change-Id: I2bb0c37fdf1112650e8adc712f60737888a8169b Reviewed-on: https://gerrit.libreoffice.org/73699 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
2019-03-07build: support disabling popplerAshod Nakashian1-0/+4
This adds --enable-poppler configure option. Poppler can be enabled/disabled by setting this parameter to yes or no. Change-Id: I42ba2d27de7b5014d28523394310616d20073b71 Reviewed-on: https://gerrit.libreoffice.org/68602 Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/68842 Tested-by: Jenkins
2019-02-10Make LDAP support optionalAndrew Udvare1-1/+2
Change-Id: Ifbd3903494a81e7b155bf6468f6ca2c50b3370a4 Reviewed-on: https://gerrit.libreoffice.org/65958 Tested-by: Jenkins Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
2018-12-28upload libcmis 0.5.2David Tardon1-1/+1
Change-Id: I0a7e888af770a332e2fec057507eecebf83621c4 Reviewed-on: https://gerrit.libreoffice.org/65646 Tested-by: Jenkins Reviewed-by: David Tardon <dtardon@redhat.com>
2018-12-17kde5: remove older kde/tde plugins, and references to thatThorsten Behrens1-27/+0
KDE4 is out of maintenance upstream since Nov. 2014, and binaries provided by TDF have switched to KDE5 as the official backend. Change-Id: I165465b56d3ba3a18912b203c06ae8fc6111c0c9 Reviewed-on: https://gerrit.libreoffice.org/60014 Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
2018-12-09Fix typo in codeAndrea Gelmini1-1/+1
Change-Id: I766d68b8e79c500aedc1741dedf662663851ffc9 Reviewed-on: https://gerrit.libreoffice.org/64742 Tested-by: Jenkins Reviewed-by: Julien Nabet <serval2412@yahoo.fr>
2018-09-22external/harfbuzz's libharfbuzz.a links against icuuc libraryStephan Bergmann1-0/+1
buovjaga reported on IRC that his build (implicitly --without-system-harfbuzz --without-system-icu) failed to link e.g. Library_vclplug_gtk3 due to harfbuzz missing symbols from ICU, like > /usr/bin/ld: /home/user/libreoffice/workdir/UnpackedTarball/harfbuzz/src/.libs/libharfbuzz.a(libharfbuzz_la-hb-icu.o): in function `hb_icu_unicode_decompose_compatibility(hb_unicode_funcs_t*, unsigned int, unsigned int*, void*)': > /home/user/libreoffice/workdir/UnpackedTarball/harfbuzz/src/hb-icu.cc:334: undefined reference to `unorm2_getNFKDInstance_62' [...] It is not clear to me why Library_vclplug_gtk3 would actually use libharfbuzz.a's hb_icu_unicode_decompose_compatibility (and for e.g. my builds, it apparently doesn't), but in general libharfbuzz.a does depend on some symbols from icuuc, so it is correct to add icuuc to the link when linking against harfbuzz. (And "gb_LinkTarget_use_external,...,icuuc" conveniently only adds libs for linking, and does not add C/C++ include file paths, which would not be wanted here.) (<https://gerrit.libreoffice.org/#/c/60882/> "Revert 'Add more more dependencies to VCL makefiles'" was a false start trying to address the above issue.) Change-Id: Ic8bcfa2aab185f8a9487d7787b4f22068e7cb481 Reviewed-on: https://gerrit.libreoffice.org/60898 Tested-by: Jenkins Reviewed-by: Ilmari Lauhakangas <ilmari.lauhakangas@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2018-09-01Update orcus to 0.14.0.Kohei Yoshida1-2/+2
And make all necessary adjustments for the new version of orcus. Change-Id: I0dc207162a3ddfaad6da198a3d13b65f530757d5 Reviewed-on: https://gerrit.libreoffice.org/59884 Tested-by: Jenkins Reviewed-by: Kohei Yoshida <libreoffice@kohei.us>
2018-08-30RepositoryExternal: mariadb needs iconv on MacOSMichael Stahl1-0/+5
Change-Id: I78928baab2ea3accfdd7db62240e39e486c2f52c
2018-08-27rename ENABLE_HEADLESS option to DISABLE_GUINoel Grandin1-1/+1
since it has nothing to do with the headless command line option, so use the name it has in the configure.ac file Change-Id: Ibf0615ed02695d6e48a797f5632e4f417c010c70 Reviewed-on: https://gerrit.libreoffice.org/59611 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
2018-08-26drop unnecessary SYSTEM_MYSQL_CONNECTOR_CPPCaolán McNamara1-37/+0
Change-Id: I41cfbf41247270d29e08e5125adc05aac198b175 Reviewed-on: https://gerrit.libreoffice.org/59608 Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
2018-08-24Moving mysqlc into connectivity as a libraryTamas Bunth1-1/+4
Additionally I erased the remains of the old mysql C++ connector. Also update the code where the clang plugins were unhappy after moving the mysqlc module. Remove mysql-cpp-connector external. Change-Id: I771cc7afacf5012fc349afb6b36828fb0fee5a66 Reviewed-on: https://gerrit.libreoffice.org/59200 Tested-by: Jenkins Reviewed-by: Tamás Bunth <btomi96@gmail.com>
2018-08-22tdf#118261 package libnumbertext data files into installation setsChristian Lohmaier1-0/+4
Change-Id: I1d4bfc9de274df2b467614fba7639e7f5a653377 Reviewed-on: https://gerrit.libreoffice.org/59421 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
2018-08-08tdf#112343 Change dependency from dbus-glib to dbusArkadiy Illarionov1-1/+1
Add check for GLib support for modules which depends on dbus and glib separately. Also fix copy-paste typo. Change-Id: Ibd33573b2f8dff9e0a7f2e0fc983d93878bb5357 Reviewed-on: https://gerrit.libreoffice.org/57157 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
2018-06-21poppler: upgrade to release 0.66.0Michael Stahl1-5/+1
Unfortunately the autotools build system was removed in 0.60.0, and the CMake one is a bit overeager in linking against system libraries that happen to be installed on the build machine, and we currently don't require CMake anyway, so avoid the problems by using a gbuild makefile and a patch to add the generated header files. Remove all current patches: poppler-notests.patch.1: obsolete (autotools build system) poppler-mac-fake.patch.1: presumed obsolete ubsan.patch.0: presumably fixed differently upstream in https://cgit.freedesktop.org/poppler/poppler/commit/?id=f43cb73939f85952d83afc87a6dc638dc1ae311b poppler-libjpeg.patch.1: obsolete (autotools build system; there appears to be no way to do this with CMake?) 0001-Fix-building-with-old-clang.patch.1: merged upstream Change-Id: I271c87ab3ec25cc9d1e8fafb04dae7c004acc350 Reviewed-on: https://gerrit.libreoffice.org/56166 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
2018-05-17Fix dependencies for CppunitTest_svl_qa_cppunit.mkMike Kaganski1-1/+1
Change-Id: I391ea52f5137975073a674ac1ad380277fe99846 Reviewed-on: https://gerrit.libreoffice.org/54381 Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> Reviewed-by: Rene Engelhard <rene@debian.org> Tested-by: Rene Engelhard <rene@debian.org> Tested-by: Jenkins <ci@libreoffice.org>
2018-05-04workdir/UnpackedTarball/libnumbertext/src/config.h is generatedStephan Bergmann1-1/+1
...from workdir/UnpackedTarball/libnumbertext/src/config.h.in, and included via lingucomponent/source/numbertext/numbertext.cxx -> workdir/UnpackedTarball/libnumbertext/src/Numbertext.hxx Change-Id: Idd007cf230b0c297c6dd692b1565336209a73ba8
2018-05-03tdf#117171 support localized number name numbering stylesLászló Németh1-0/+53
in page number, chapter and outline numbering in ~30 languages by integrating libnumbertext library. - offapi: add linguistic2::NumberText New NumberingType constants: - ordinal indicators (1st, 2nd, 3rd...) - cardinal number names (One, Two, Three...) - ordinal number names (First, Second, Third...) Note: these numberings are parts of OOXML, too. Plain text files of Libnumbertext's language data are installed in share/numbertext (similar to share/fingerprint), allowing further customization. Change-Id: I4034da0a40a8c926f14a3f591749a89a8d807d5a Reviewed-on: https://gerrit.libreoffice.org/53313 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: László Németh <nemeth@numbertext.org>
2018-04-25Install UCRT from MSUs, not using nested VC Redist installMike Kaganski1-2/+2
Using nested install is bad because (1) MS advises against it (though it most possibly doesn't relate to our specific case, when we install the vc redist exe package in UI part, so actually only a single MSI session is active at any time); (2) because it adds some extra interactions (user sees something "unrelated" being installed, which raises concerns; additional admin authentication required); and (3) because it runs in InstallUISequence, thus only installing the UCRT when doing interactive installation (unattended installs, including GPO, need to install UCRT separately). This patch aims to incorporate the original UCRT MSU (Windows Update) packages (https://support.microsoft.com/en-us/help/2999226) available as a zip archive from https://www.microsoft.com/en-us/download/details.aspx?id=48234 - the same as used in VC redists for VS 2015 and 2017. This obsoletes the separate installation of the redist; since we also have the redist as merge module in our MSI, that is enough (and removes redundancy). The MSUs are installed using wusa.exe in a custom action (deferred, non-impersonating). As a small bonus, embedding MSUs instead of redist EXE allows us to shrink the size of installer a little (~10 MB). As deferred custom actions cannot access current installer database, we workaround this by using initial immediate impersonating action to extract the binaries into a temporary location. To ensure that the file gets removed upon completion (both successful and failed), we use an additional cleanup action. Commit 61b1d631331551b43bc7d619be33bfbfeff7cad6 is effectively reverted. Change-Id: I1529356fdcc67ff24b232c01ddf8bb3a31bb00bd Reviewed-on: https://gerrit.libreoffice.org/52923 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
2018-04-12Revert "Remove dead HSQLDB driver"Sophia Schröder1-0/+47
We cannot silently convert user data or their used file formats and then await them to accept it or reinstall an older version. Let us make a soft change instead of an hard (heart) break and avoid us to been attacked with fire and forks from our users. This reverts commit 8d381ae8d6c742a7e15bf7ad9e07b65f81728ef6. Change-Id: Ia153640935e355771acb85cf652f8fe4c21fafbb Reviewed-on: https://gerrit.libreoffice.org/52731 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Tamás Bunth <btomi96@gmail.com>
2018-04-10Remove dead HSQLDB driverTamas Bunth1-47/+0
Change-Id: Id4cfb69079f0150c9cca2626c16df7fab441d916 Reviewed-on: https://gerrit.libreoffice.org/52611 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Tamás Bunth <btomi96@gmail.com>
2018-03-08Improve gpgmepp -> libassuan/libgpg-error lib dependenciesStephan Bergmann1-11/+0
...so that other executables than svidl would benefit, too Change-Id: I208ebbc04189c2f25eace19ef0875349cf63d3f0 Reviewed-on: https://gerrit.libreoffice.org/50963 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2018-03-08Probably better to comment on these dependenciesStephan Bergmann1-0/+3
...added with f23651ff10da2d4bbbc47d0152b5cc321c29f0d1 "Missing dependencies" Change-Id: I4cd02fc8b242b3a3737305546bf3155425614d65
2018-03-07Missing dependenciesStephan Bergmann1-0/+8
Change-Id: Iabdc81c9df2cc50ec4f4713af42d2fb9c3cc1f43 Reviewed-on: https://gerrit.libreoffice.org/50915 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2018-02-28Build external lxml if not provided by systemSamuel Thibault1-0/+1
except on windows, where gla11y will resort to python's internal xml parser, which does not provide line numbers. This allows gla11y to be runnable on all systems. Change-Id: Ica4eb90f59bddfcefd783fc2ed9c8c27357e7572 Reviewed-on: https://gerrit.libreoffice.org/50115 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2018-02-03tdf#114635: Add TWAINDSM.DLL to 64-bit Windows packageMike Kaganski1-2/+8
This patch allows us to use our own bundled TWAINDSM.dll (from twain-dsm project, http://www.twain.org, https://github.com/twain/twain-dsm) on 64-bit Windows systems that don't have their own TWAIN DLL, and without requiring users to install it from some other source. The DLL is put into INSTALLOCATION/program along soffice.bin. Of course, TWAIN sources still need to be 64-bit themselves (i.e., true 64-bit TWAIN drivers required) to be usable by 64-bit program. Also this drops external/twain/inc/twain/twain.h, which is an old version copied from twain-dsm, and instead uses the tarball to get the header (required by Library_scn on both 32- and 64-bit Windows). Change-Id: I191027f3221ce46db17f50db91c9cb9315900810 Reviewed-on: https://gerrit.libreoffice.org/46992 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Jenkins <ci@libreoffice.org>
2018-01-23Extend build system to support linking against KDE Frameworks 5Milian Wolff1-0/+35
Pass --enable-kde5 to autogen.sh to enable this feature. Then add kde5 to the list of externals to link against KF5. I will introduce other code that depends on KF5 though which will leverage this feature. Change-Id: I17e434a53ac769000b0f805b1f41cdc5c2c84ee2 Reviewed-on: https://gerrit.libreoffice.org/47715 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>