summaryrefslogtreecommitdiff
path: root/sysui/desktop/freedesktop/freedesktop-menus.spec
diff options
context:
space:
mode:
Diffstat (limited to 'sysui/desktop/freedesktop/freedesktop-menus.spec')
-rwxr-xr-x[-rw-r--r--]sysui/desktop/freedesktop/freedesktop-menus.spec10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysui/desktop/freedesktop/freedesktop-menus.spec b/sysui/desktop/freedesktop/freedesktop-menus.spec
index 1649971dad99..30c2dd61e839 100644..100755
--- a/sysui/desktop/freedesktop/freedesktop-menus.spec
+++ b/sysui/desktop/freedesktop/freedesktop-menus.spec
@@ -7,7 +7,7 @@ Name: %pkgprefix-freedesktop-menus
#BuildRequires: perl
Group: Office
License: LGPL
-Provides: openoffice.org3-desktop-integration
+Provides: libreoffice-desktop-integration
Conflicts: %pkgprefix-suse-menus
Conflicts: %pkgprefix-debian-menus
Conflicts: %pkgprefix-redhat-menus
@@ -187,7 +187,7 @@ if [ "$1" = 1 ]
then
# backing out existing entries to avoid duplicates
sed '
-/^# OpenOffice.org/d
+/^# LibreOffice/d
/^application\/vnd\.oasis\.opendocument/d
/^application\/vnd\.openofficeorg/d
/^application\/vnd\.sun/d
@@ -203,7 +203,7 @@ then
# now append our stuff to the temporary file
cat >> /etc/mailcap.tmp$$ << END
-# OpenOffice.org
+# LibreOffice
application/vnd.oasis.opendocument.text; %unixfilename -view %s
application/vnd.oasis.opendocument.text-template; %unixfilename -view %s
application/vnd.oasis.opendocument.text-web; %unixfilename -view %s
@@ -318,6 +318,10 @@ done
# glibc breaks rpm unless rpm is build with internal glob-matching (issue 49374)
# https://bugzilla.redhat.com/beta/show_bug.cgi?id=134362
%defattr(-, root, root)
+%if %unixfilename != libreoffice
+# compat symlinks
+%attr(0755, root, root) /opt/%unixfilename
+%endif
%attr(0755, root, root) /usr/bin/*
/usr/share/applications/%unixfilename-base.desktop
/usr/share/applications/%unixfilename-calc.desktop