summaryrefslogtreecommitdiff
path: root/offapi/com/sun/star/packages/manifest
diff options
context:
space:
mode:
Diffstat (limited to 'offapi/com/sun/star/packages/manifest')
-rw-r--r--offapi/com/sun/star/packages/manifest/XManifestReader.idl56
-rw-r--r--offapi/com/sun/star/packages/manifest/XManifestWriter.idl57
-rw-r--r--offapi/com/sun/star/packages/manifest/makefile.mk47
3 files changed, 160 insertions, 0 deletions
diff --git a/offapi/com/sun/star/packages/manifest/XManifestReader.idl b/offapi/com/sun/star/packages/manifest/XManifestReader.idl
new file mode 100644
index 000000000000..91f589ee258e
--- /dev/null
+++ b/offapi/com/sun/star/packages/manifest/XManifestReader.idl
@@ -0,0 +1,56 @@
+/*************************************************************************
+ *
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * Copyright 2000, 2010 Oracle and/or its affiliates.
+ *
+ * OpenOffice.org - a multi-platform office productivity suite
+ *
+ * This file is part of OpenOffice.org.
+ *
+ * OpenOffice.org is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License version 3
+ * only, as published by the Free Software Foundation.
+ *
+ * OpenOffice.org is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU Lesser General Public License version 3 for more details
+ * (a copy is included in the LICENSE file that accompanied this code).
+ *
+ * You should have received a copy of the GNU Lesser General Public License
+ * version 3 along with OpenOffice.org. If not, see
+ * <http://www.openoffice.org/license.html>
+ * for a copy of the LGPLv3 License.
+ *
+ ************************************************************************/
+#ifndef __com_sun_star_packages_manifest_XManifestReader_idl__
+#define __com_sun_star_packages_manifest_XManifestReader_idl__
+
+#ifndef __com_sun_star_beans_PropertyValue_idl__
+#include <com/sun/star/beans/PropertyValue.idl>
+#endif
+
+#ifndef __com_sun_star_io_XInputStream_idl__
+#include <com/sun/star/io/XInputStream.idl>
+#endif
+
+//=============================================================================
+
+module com { module sun { module star { module packages { module manifest {
+
+//=============================================================================
+/** This interface reads the manifest data from a file. The user
+ must supply an XInputStream when calling readManifestSequence() to recieve
+ a sequence of manifest entries. Each manifest entry is represented by
+ a sequence of PropertyValues. */
+//=============================================================================
+published interface XManifestReader: com::sun::star::uno::XInterface
+{
+ /** Supplies the XManifestReader with an XInputStream to read from, reads
+ the data and returns it to the caller.
+ */
+ sequence < sequence < com::sun::star::beans::PropertyValue > > readManifestSequence( [in] com::sun::star::io::XInputStream rStream );
+};
+}; }; }; }; };
+#endif
diff --git a/offapi/com/sun/star/packages/manifest/XManifestWriter.idl b/offapi/com/sun/star/packages/manifest/XManifestWriter.idl
new file mode 100644
index 000000000000..c38b9cacaf76
--- /dev/null
+++ b/offapi/com/sun/star/packages/manifest/XManifestWriter.idl
@@ -0,0 +1,57 @@
+/*************************************************************************
+ *
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * Copyright 2000, 2010 Oracle and/or its affiliates.
+ *
+ * OpenOffice.org - a multi-platform office productivity suite
+ *
+ * This file is part of OpenOffice.org.
+ *
+ * OpenOffice.org is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License version 3
+ * only, as published by the Free Software Foundation.
+ *
+ * OpenOffice.org is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU Lesser General Public License version 3 for more details
+ * (a copy is included in the LICENSE file that accompanied this code).
+ *
+ * You should have received a copy of the GNU Lesser General Public License
+ * version 3 along with OpenOffice.org. If not, see
+ * <http://www.openoffice.org/license.html>
+ * for a copy of the LGPLv3 License.
+ *
+ ************************************************************************/
+#ifndef __com_sun_star_packages_manifest_XManifestWriter_idl__
+#define __com_sun_star_packages_manifest_XManifestWriter_idl__
+
+#ifndef __com_sun_star_beans_PropertyValue_idl__
+#include <com/sun/star/beans/PropertyValue.idl>
+#endif
+
+#ifndef __com_sun_star_io_XOutputStream_idl__
+#include <com/sun/star/io/XOutputStream.idl>
+#endif
+
+//=============================================================================
+
+module com { module sun { module star { module packages { module manifest {
+
+/** This interface writes the manifest data to a file. The user
+ calls writeManifestSequence() with the XOutputStream to write the data to
+ and the sequence of manifest entries to be written passed as parameters.
+ Each manifest entry is represented by a sequence of PropertyValues.*/
+
+//=============================================================================
+published interface XManifestWriter: com::sun::star::uno::XInterface
+{
+ /** Writes the supplied sequence of manifest entries to the supplied
+ XOutputStream
+ */
+ void writeManifestSequence([in] com::sun::star::io::XOutputStream rStream,
+ [in] sequence < sequence < com::sun::star::beans::PropertyValue > > rSequence );
+};
+}; }; }; }; };
+#endif
diff --git a/offapi/com/sun/star/packages/manifest/makefile.mk b/offapi/com/sun/star/packages/manifest/makefile.mk
new file mode 100644
index 000000000000..9be92686a918
--- /dev/null
+++ b/offapi/com/sun/star/packages/manifest/makefile.mk
@@ -0,0 +1,47 @@
+#*************************************************************************
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# Copyright 2000, 2010 Oracle and/or its affiliates.
+#
+# OpenOffice.org - a multi-platform office productivity suite
+#
+# This file is part of OpenOffice.org.
+#
+# OpenOffice.org is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License version 3
+# only, as published by the Free Software Foundation.
+#
+# OpenOffice.org is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License version 3 for more details
+# (a copy is included in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU Lesser General Public License
+# version 3 along with OpenOffice.org. If not, see
+# <http://www.openoffice.org/license.html>
+# for a copy of the LGPLv3 License.
+#
+#*************************************************************************
+
+PRJ=..$/..$/..$/..$/..
+
+PRJNAME=offapi
+
+TARGET=cssmanifest
+PACKAGE=com$/sun$/star$/packages$/manifest
+
+# --- Settings -----------------------------------------------------
+.INCLUDE : $(PRJ)$/util$/makefile.pmk
+
+# ------------------------------------------------------------------------
+
+IDLFILES=\
+ XManifestReader.idl\
+ XManifestWriter.idl
+
+# ------------------------------------------------------------------
+
+.INCLUDE : target.mk
+.INCLUDE : $(PRJ)$/util$/target.pmk