summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 19beb9ae6c8b..17df05396acc 100644
--- a/configure.in
+++ b/configure.in
@@ -40,9 +40,14 @@ AC_SUBST(CROSS_COMPILING)
if test "$build_os" = "cygwin"; then
EXEEXT_FOR_BUILD=.exe
+ SRC_ROOT=`pwd`
+ SRC_ROOT=`cygpath -d "$SRC_ROOT"`
+ SRC_ROOT=`cygpath -u "$SRC_ROOT"`
else
EXEEXT_FOR_BUILD=
+ SRC_ROOT=`pwd`
fi
+AC_SUBST(SRC_ROOT)
AC_SUBST(EXEEXT_FOR_BUILD)
cat /dev/null > warn
@@ -9548,7 +9553,7 @@ else
echo > set_soenv.last
fi
-AC_CONFIG_FILES([ooo.lst set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh])
+AC_CONFIG_FILES([ooo.lst set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh build_env])
AC_OUTPUT
# make sure this is executable