summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 70d7b7f722f8..0c5093e8f007 100644
--- a/configure.in
+++ b/configure.in
@@ -408,6 +408,13 @@ AC_ARG_ENABLE(scripting,
[Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
)
+# This is mainly for iOS, but could potentially be used in some
+# special case otherwise, too, so factored out as a separate setting
+AC_ARG_ENABLE(dynamic-loading,
+ AS_HELP_STRING([--disable-dynamic-loading],
+ [Disable any use of dynamic loading of code. Work in progress, use only if you are hacking on it.])
+)
+
AC_ARG_ENABLE(ext-diagram,
AS_HELP_STRING([--enable-ext-diagram],
[Enable the SmART Gallery (Diagram) extension.])
@@ -2093,6 +2100,23 @@ else
fi
AC_SUBST(DISABLE_SCRIPTING)
+if test $_os = iOS; then
+ # Disable dynamic_loading always for iOS
+ enable_dynamic_loading=no
+elif test -z "$enable_dynamic_loading"; then
+ # Otherwise enable it unless speficically disabled
+ enable_dynamic_loading=yes
+fi
+
+DISABLE_DYNLOADING=''
+if test "$enable_dynamic_loading" = yes; then
+ BUILD_TYPE="$BUILD_TYPE DYNLOADING"
+else
+ DISABLE_DYNLOADING='TRUE'
+ SCPDEFS="$SCPDEFS -DDISABLE_DYNLOADING"
+fi
+AC_SUBST(DISABLE_DYNLOADING)
+
dnl ===================================================================
dnl Extra check for Windows. Cygwin builds need gcc to build dmake
dnl although MSVC is used to build other build-time tools and