summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac85
1 files changed, 26 insertions, 59 deletions
diff --git a/configure.ac b/configure.ac
index 8756e529a9b1..76da4e4703e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2097,10 +2097,9 @@ libo_FUZZ_ARG_WITH(doxygen,
,with_doxygen=yes)
AC_ARG_WITH(visual-studio,
- AS_HELP_STRING([--with-visual-studio=<2013/2015/2017>],
+ AS_HELP_STRING([--with-visual-studio=<2015/2017>],
[Specify which Visual Studio version to use in case several are
- installed. If not specified, only 2013 is detected automatically
- because 2015 and 2017 support is currently experimental.]),
+ installed. If not specified, defaults to 2015.]),
,)
AC_ARG_WITH(windows-sdk,
@@ -3269,8 +3268,6 @@ map_vs_year_to_version()
unset vsversion
case $1 in
- 2013)
- vsversion=12.0;;
2015)
vsversion=14.0;;
2017)
@@ -3291,8 +3288,8 @@ vs_versions_to_check()
map_vs_year_to_version "$1"
vsversions=$vsversion
else
- # By default we prefer 2013/2015/2017, in this order
- vsversions="12.0 14.0 15.0"
+ # By default we prefer 2015/2017, in this order
+ vsversions="14.0 15.0"
fi
}
@@ -3348,7 +3345,7 @@ find_ucrt()
find_msvc()
{
- # Find Visual C++ 2013/2015/2017
+ # Find Visual C++ 2015/2017
# Args: $1 (optional) : The VS version year
# Return values: $vctest, $vcyear, $vcnum, $vcnumwithdot, $vcbuildnumber
@@ -3382,10 +3379,6 @@ find_msvc()
if test -n "$vctest"; then
vcnumwithdot=$ver
case "$vcnumwithdot" in
- 12.0)
- vcyear=2013
- vcnum=120
- ;;
14.0)
vcyear=2015
vcnum=140
@@ -3415,7 +3408,7 @@ if test "$_os" = "WINNT"; then
if test -n "$with_visual_studio"; then
AC_MSG_ERROR([No Visual Studio $with_visual_studio installation found])
else
- AC_MSG_ERROR([No Visual Studio 2013/2015/2017 installation found])
+ AC_MSG_ERROR([No Visual Studio 2015/2017 installation found])
fi
fi
@@ -3454,27 +3447,21 @@ if test "$_os" = "WINNT"; then
UCRTSDKDIR=
UCRTVERSION=
- AC_MSG_CHECKING([whether UCRT is needed for this compiler version])
- if test "$vcnum" = "120"; then
- AC_MSG_RESULT([No])
- else
- AC_MSG_RESULT([Yes])
- AC_MSG_CHECKING([for UCRT location])
- find_ucrt
- if test -n "$UCRTSDKDIR"; then
- AC_MSG_RESULT([found])
- PathFormat "${UCRTSDKDIR}Include/$UCRTVERSION/ucrt"
- ucrtincpath_formatted=$formatted_path
- # SOLARINC is used for external modules and must be set too.
- # And no, it's not sufficient to set SOLARINC only, as configure
- # itself doesn't honour it.
- SOLARINC="$SOLARINC -I$ucrtincpath_formatted"
- CFLAGS="$CFLAGS -I$ucrtincpath_formatted"
- CXXFLAGS="$CXXFLAGS -I$ucrtincpath_formatted"
- CPPFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
- else
- AC_MSG_ERROR([not found])
- fi
+ AC_MSG_CHECKING([for UCRT location])
+ find_ucrt
+ if test -n "$UCRTSDKDIR"; then
+ AC_MSG_RESULT([found])
+ PathFormat "${UCRTSDKDIR}Include/$UCRTVERSION/ucrt"
+ ucrtincpath_formatted=$formatted_path
+ # SOLARINC is used for external modules and must be set too.
+ # And no, it's not sufficient to set SOLARINC only, as configure
+ # itself doesn't honour it.
+ SOLARINC="$SOLARINC -I$ucrtincpath_formatted"
+ CFLAGS="$CFLAGS -I$ucrtincpath_formatted"
+ CXXFLAGS="$CXXFLAGS -I$ucrtincpath_formatted"
+ CPPFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
+ else
+ AC_MSG_ERROR([not found])
fi
AC_SUBST(UCRTSDKDIR)
AC_SUBST(UCRTVERSION)
@@ -3501,10 +3488,6 @@ if test "$_os" = "WINNT"; then
# Find the version of devenv.exe
DEVENV="$VC_PRODUCT_DIR/../Common7/IDE/devenv.exe"
- if test ! -e "$DEVENV" -a "$vcnum" = "120"; then
- # for Visual Studio 2013 Express, fall back
- DEVENV="$VC_PRODUCT_DIR/../Common7/IDE/WDExpress.exe"
- fi
if test ! -e "$DEVENV"; then
AC_MSG_ERROR([No devenv.exe found, Visual Studio installation broken?])
fi
@@ -3518,13 +3501,8 @@ if test "$_os" = "WINNT"; then
CL_LIB=
if test "$BITNESS_OVERRIDE" = ""; then
- if test "$vcnum" = "120"; then
- MSPDB_PATH="$VC_PRODUCT_DIR/../VC/bin"
- CL_DIR=bin
- else
- MSPDB_PATH="$VC_PRODUCT_DIR/../Common7/IDE"
- CL_DIR=bin
- fi
+ MSPDB_PATH="$VC_PRODUCT_DIR/../Common7/IDE"
+ CL_DIR=bin
else
if test "$vcexpress" = "Express"; then
MSPDB_PATH="$VC_PRODUCT_DIR/bin"
@@ -3627,10 +3605,6 @@ if test "$_os" = "WINNT"; then
# are always "better", we list them in reverse chronological order.
case $vcnum in
- 120)
- COMEX=15
- WINDOWS_SDK_ACCEPTABLE_VERSIONS="8.1A 8.1 8.0 7.1A"
- ;;
140)
COMEX=19
WINDOWS_SDK_ACCEPTABLE_VERSIONS="10.0A 10.0 8.1A 8.1 8.0 7.1A"
@@ -5324,7 +5298,7 @@ find_msms()
my_msm_file=Microsoft_VC${VCVER}_CRT_x86.msm
AC_MSG_CHECKING([for $my_msm_file])
msmdir=
- for ver in 12.0 14.0 15.0; do
+ for ver in 14.0 15.0; do
reg_get_value_32 HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VS/MSMDir
if test -n "$regvalue"; then
if test -e "$regvalue/$my_msm_file"; then
@@ -8127,14 +8101,7 @@ int main(int argc, char **argv) {
internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
- # On windows we are supporting two different python versions: 3.3 and 3.5.
- # We msut do it as long as we support MSVC 2013. Python 3.3 can be removed
- # when MSVC 2013 support was dropped.
- if test "$COM" = "MSC" -a "$VCVER" = "120"; then
- PYTHON_VERSION_MINOR=3
- else
- PYTHON_VERSION_MINOR=5
- fi
+ PYTHON_VERSION_MINOR=5
PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.0
AC_DEFINE_UNQUOTED([PYTHON_VERSION_STRING], [L"${PYTHON_VERSION}"])
BUILD_TYPE="$BUILD_TYPE PYTHON"
@@ -12781,7 +12748,7 @@ place yourself in a working directory of you choice.
git clone git://git.savannah.gnu.org/make.git
- [go to Start menu, click "All Programs", click "Visual Studio 2013", click "Visual Studio Tools", double-click "VS2013 x86 Native Tools Command Prompt" or "VS2013 x64 Native Tools Command Prompt"]
+ [go to Start menu, click "All Programs", click "Visual Studio 2015", click "Visual Studio Tools", double-click "VS2015 x86 Native Tools Command Prompt" or "VS2015 x64 Native Tools Command Prompt"]
set PATH=%PATH%;C:\Cygwin\bin
[or Cygwin64, if that is what you have]
cd path-to-make-repo-you-cloned-above