summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f45d8fde9866..b730bd2870ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8503,6 +8503,7 @@ if test "$with_java" != "no"; then
AC_MSG_RESULT([internal])
SYSTEM_HSQLDB=
BUILD_TYPE="$BUILD_TYPE HSQLDB"
+ NEED_ANT=TRUE
AC_MSG_CHECKING([whether hsqldb should be built with JDBC 4.1])
javanumver=`$JAVAINTERPRETER -version 2>&1 | $AWK -v num=true -f $SRC_ROOT/solenv/bin/getcompver.awk`
if expr "$javanumver" '>=' 000100060000 > /dev/null; then
@@ -10617,6 +10618,7 @@ if test "$enable_report_builder" != "no" -a "$with_java" != "no"; then
AC_MSG_RESULT([internal])
SYSTEM_JFREEREPORT=
BUILD_TYPE="$BUILD_TYPE JFREEREPORT"
+ NEED_ANT=TRUE
fi
else
AC_MSG_RESULT([no])
@@ -10660,6 +10662,7 @@ if test "$ENABLE_REPORTBUILDER" = "TRUE"; then
AC_MSG_RESULT([internal])
SYSTEM_APACHE_COMMONS=
BUILD_TYPE="$BUILD_TYPE APACHE_COMMONS"
+ NEED_ANT=TRUE
fi
fi
AC_SUBST(SYSTEM_APACHE_COMMONS)
@@ -10722,6 +10725,7 @@ if test "${enable_scripting_javascript}" != "no" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([internal])
SYSTEM_RHINO=
BUILD_TYPE="$BUILD_TYPE RHINO"
+ NEED_ANT=TRUE
fi
else
AC_MSG_RESULT([no])
@@ -11650,7 +11654,7 @@ dnl ===================================================================
dnl Test for the presence of Ant and that it works
dnl ===================================================================
-if test "$ENABLE_JAVA" != ""; then
+if test "$ENABLE_JAVA" != "" -a "$NEED_ANT" = "TRUE"; then
ANT_HOME=; export ANT_HOME
WITH_ANT_HOME=; export WITH_ANT_HOME
if test -z "$with_ant_home" -a -n "$LODE_HOME" ; then