summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 93a75985517c..c4fefead2e8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4292,6 +4292,12 @@ linux-gnu*)
case "$host_cpu" in
+ aarch64)
+ CPUNAME=AARCH64
+ PLATFORMID=linux_aarch64
+ RTL_ARCH=AARCH64
+ OUTPATH=unxlngaarch64
+ ;;
alpha)
CPUNAME=AXP
RTL_ARCH=ALPHA
@@ -6903,7 +6909,7 @@ if test "$ENABLE_JAVA" != ""; then
# at least 2 reasons to check: officebean needs to link -ljawt,
# and libjpipe.so needs to be loaded by java to run JunitTests.
case $CPUNAME in
- AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64)
+ AARCH64|AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64)
if test -f "$JAVAINTERPRETER" -a "`$JAVAINTERPRETER -version 2>&1 | $GREP -i 64-bit`" = "" >/dev/null; then
AC_MSG_WARN([You are building 64-bit binaries but the JDK $JAVAINTERPRETER is 32-bit])
AC_MSG_ERROR([You should pass the --with-jdk-home option pointing to a 64-bit JDK])