summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8aa33d043998..5dbe640b4bd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11483,9 +11483,8 @@ test_font_map()
FONTFILE_LOWER="$(echo $FONTFILE | $AWK '{print tolower($0)}')"
TESTEXPR="'${FONTFILE_LOWER}' = '$(echo $FONT | $AWK '{print tolower($0)}').ttf'"
- while true ; do
+ while test "$#" -ge 1 ; do
MAPPING="$(echo $1 | $AWK '{print tolower($0)}')"; shift
- test -n "$MAPPING" || break
TESTEXPR="${TESTEXPR} -o '${FONTFILE_LOWER}' = '$MAPPING-regular.ttf'"
done
if test $TESTEXPR