summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4029a5f5a34..ac3dc4e93f0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4538,7 +4538,12 @@ if test -n "$enable_werror" -a "$enable_werror" != "no"; then
ENABLE_WERROR="TRUE"
AC_MSG_RESULT([yes])
else
- AC_MSG_RESULT([no])
+ if test -n "$LODE_HOME"; then
+ ENABLE_WERROR="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
AC_SUBST(ENABLE_WERROR)