summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e1f22548b332..d8401fc5b4e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10210,6 +10210,7 @@ else
fi
AC_SUBST(ENABLE_VLC)
+# this is for opengl transitions in impress slideshow
ENABLE_OPENGL=
if test $_os = iOS -o $_os = Android; then
: # disable
@@ -10226,7 +10227,9 @@ elif test $_os = WINNT; then
SYSTEM_MESA_HEADERS=
BUILD_TYPE="$BUILD_TYPE MESA"
else
- ENABLE_OPENGL=TRUE
+ if test "$with_x" != "no"; then
+ ENABLE_OPENGL=TRUE
+ fi
ENABLE_OPENGL_CANVAS=TRUE
dnl ===================================================================