summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de685d69bdaf..4b518314018a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1997,6 +1997,15 @@ AC_ARG_WITH(startcenter-space-bitmap,
Usage: --with-startcenter-space-bitmap=/path/my_backing_space.png
],,)
+AC_ARG_WITH(extra-buildid,
+ AS_HELP_STRING([--with-extra-buildid],
+ [Show addition build identification in about dialog.])
+ [
+ Usage: --with-extra-buildid="Tinderbox: Win-x86@6, Branch:master, Date:2012-11-26_00.29.34"
+ ],
+,)
+
+
AC_ARG_WITH(vendor,
AS_HELP_STRING([--with-vendor],
[Set vendor of the build.])
@@ -11996,6 +12005,16 @@ else
fi
AC_SUBST(STARTCENTER_SPACE_BITMAP)
+EXTRA_BUILDID=
+AC_MSG_CHECKING([for extra build ID])
+if test -n "$with_extra_buildid" -a "$with_extra_buildid" != "yes" ; then
+ EXTRA_BUILDID="$with_extra_buildid"
+ AC_MSG_RESULT([$EXTRA_BUILDID])
+else
+ AC_MSG_RESULT([not set])
+fi
+AC_SUBST(EXTRA_BUILDID)
+
OOO_VENDOR=
AC_MSG_CHECKING([for vendor])
if test -z "$with_vendor" -o "$with_vendor" = "no"; then