summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 7189dd37b5c6..f390643d6aad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ dnl in order to create a configure script.
# several non-alphanumeric characters, those are split off and used only for the
# ABOUTBOXPRODUCTVERSIONSUFFIX in openoffice.lst. Why that is necessary, no idea.
-AC_INIT([LibreOffice],[6.1.6.3.M13],[],[],[http://documentfoundation.org/])
+AC_INIT([LibreOffice],[6.1.6.3.M17],[],[],[http://documentfoundation.org/])
AC_PREREQ([2.59])
@@ -5240,16 +5240,17 @@ find_winsdk_version()
reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/v${1}/ProductVersion"
if test -n "$regvalue"; then
winsdkbinsubdir="$regvalue".0
- fi
- winsdklibsubdir=$regvalue
- if test "$regvalue" = "10.0.14393"; then
- winsdklibsubdir="10.0.14393.0"
- elif test "$regvalue" = "10.0.16299"; then
- winsdklibsubdir="10.0.16299.0"
- elif test "$regvalue" = "10.0.15063"; then
- winsdklibsubdir="10.0.15063.0"
- elif test "$regvalue" = "10.0.17134"; then
- winsdklibsubdir="$regvalue.0"
+ winsdklibsubdir=$winsdkbinsubdir
+ tmppath="$winsdktest\\Include\\$winsdklibsubdir"
+ # test exist the SDK path
+ if test -d "$tmppath"; then
+ # when path is convertable to a short path then path is okay
+ if ! cygpath -d "$tmppath"; then
+ AC_MSG_ERROR([Windows SDK doesn't have a 8.3 name, see NtfsDisable8dot3NameCreation])
+ fi
+ else
+ AC_MSG_ERROR([The Windows SDK not found, check the installation])
+ fi
fi
return
fi
@@ -8289,7 +8290,7 @@ internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=5
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.7
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.9
if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])
fi