summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d7be9959e8b8..93bf839fb815 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2741,8 +2741,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what Mac OS X SDK to use])
-
- for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12 10.13; do
+ for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12 10.13 10.14; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2779,6 +2778,9 @@ if test $_os = Darwin; then
10.13)
MACOSX_SDK_VERSION=101300
;;
+ 10.14)
+ MACOSX_SDK_VERSION=101400
+ ;;
*)
AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--13])
;;
@@ -2818,6 +2820,9 @@ if test $_os = Darwin; then
10.13)
MAC_OS_X_VERSION_MIN_REQUIRED="101300"
;;
+ 10.14)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101400"
+ ;;
*)
AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--13])
;;
@@ -2861,6 +2866,9 @@ if test $_os = Darwin; then
10.13)
MAC_OS_X_VERSION_MAX_ALLOWED="101300"
;;
+ 10.14)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101400"
+ ;;
*)
AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--13])
;;