summaryrefslogtreecommitdiff
path: root/sysui/desktop/debian
diff options
context:
space:
mode:
authorOliver Bolte <obo@openoffice.org>2005-07-18 12:58:27 +0000
committerOliver Bolte <obo@openoffice.org>2005-07-18 12:58:27 +0000
commit9cd87e82c0da4625e8d1d7fa347f2e6de8b69eb7 (patch)
treee8c2fe2300a65138e98e38aabd036ce46929f59d /sysui/desktop/debian
parent70a7f20dfb02d5871d7473683e2cf51df8300073 (diff)
INTEGRATION: CWS sysui09 (1.3.2); FILE MERGED
2005/07/14 09:19:18 obr 1.3.2.3: #i51593# exclude control file from the chmod as suggested by attached patch 2005/07/14 09:15:06 obr 1.3.2.2: #i51593# fix permissions for DEBIAN directory for umask 027 2005/07/05 07:05:27 obr 1.3.2.1: - introduced virtual package openofficeorg-desktop-integration. - removed Windows style HighContrast icons from packages - moved build arch parameter to spec files - introduced debian/control
Diffstat (limited to 'sysui/desktop/debian')
-rw-r--r--sysui/desktop/debian/makefile.mk25
1 files changed, 9 insertions, 16 deletions
diff --git a/sysui/desktop/debian/makefile.mk b/sysui/desktop/debian/makefile.mk
index 61e4c5d6e3e5..d3f4c80953ab 100644
--- a/sysui/desktop/debian/makefile.mk
+++ b/sysui/desktop/debian/makefile.mk
@@ -106,7 +106,7 @@ MIMELIST = \
oasis-database \
oasis-web-template
-HCMIMEICONLIST = \
+MIMEICONLIST = \
oasis-text \
oasis-text-template \
oasis-spreadsheet \
@@ -118,9 +118,7 @@ HCMIMEICONLIST = \
oasis-formula \
oasis-master-document \
oasis-database \
- oasis-web-template
-
-MIMEICONLIST = $(HCMIMEICONLIST) \
+ oasis-web-template \
text \
text-template \
spreadsheet \
@@ -171,7 +169,6 @@ DEBDEPN = \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/mime-info/$(UNIXFILENAME).mime \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/mimelnk/application.flag \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/gnome/{$(GNOMEICONLIST)} \
- $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/{$(HCICONLIST)} \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/{$(KDEICONLIST)}
DEBDIR = $(shell cd $(BIN); pwd)
@@ -211,10 +208,6 @@ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/gnome/{$(GNOMEICONLIST)} : ../ico
@$(MKDIRHIER) $(@:d)
@$(COPY) $< $@
-$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/{$(HCICONLIST)} : ../icons/$$(@:d:d:d:d:d:d:f)/$$(@:d:d:d:d:f)/$$(@:d:d:f)/$$(@:f:s/$(ICONPREFIX)-//)
- @$(MKDIRHIER) $(@:d)
- @$(COPY) $< $@
-
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/icons/{$(KDEICONLIST)} : ../icons/$$(@:d:d:d:d:d:d:f)/$$(@:d:d:d:d:f)/$$(@:d:d:f)/$$(@:f:s/$(ICONPREFIX)-//)
@$(MKDIRHIER) $(@:d)
@$(COPY) $< $@
@@ -273,21 +266,21 @@ $(MISC)/$(TARGET)/$(DEBFILE:f)/etc/$(UNIXFILENAME) :
@$(MKDIRHIER) $(@:d)
@ln -sf /opt/openoffice.org$(PKGVERSION) $@
+
+
# --- packaging ---------------------------------------------------
# getuid.so fakes the user/group for us
$(DEBFILE) : $(DEBDEPN)
@$(MKDIRHIER) $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN
- @echo "Package: openofficeorg-debian-menus" > $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
+ @cat control | tr -d "\015" > $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
@echo "Version: $(PKGVERSION)" >> $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
- @echo "Description: OpenOffice.org desktop integration" >> $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
- @echo "Maintainer: OpenOffice.org" >> $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
- @echo "Architecture: all" >> $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/control
@cat postinst | tr -d "\015" | sed -e "s/%PREFIX/$(UNIXFILENAME)/g" > $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/postinst
@cat postrm | tr -d "\015" | sed -e "s/%PREFIX/$(UNIXFILENAME)/g" > $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/postrm
@cat prerm | tr -d "\015" | sed -e "s/%PREFIX/$(UNIXFILENAME)/g" > $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/prerm
@chmod -R g-w $(MISC)/$(TARGET)/$(DEBFILE:f)
- @chmod a+x $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/post* $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/pre*
- /bin/bash -c "LD_PRELOAD=$(SOLARBINDIR)/getuid.so dpkg-deb --build $(MISC)/$(TARGET)/$(DEBFILE:f) $(DEBFILE)"
- @chmod -R g+w $(MISC)/$(TARGET)/$(DEBFILE:f)
+ @chmod a+rx $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/post* $(MISC)/$(TARGET)/$(DEBFILE:f)/DEBIAN/pre*
+ /bin/bash -c "LD_PRELOAD=$(SOLARBINDIR)/getuid.so dpkg-deb --build $(MISC)/$(TARGET)/$(@:f) $@"
+ @chmod -R g+w $(MISC)/$(TARGET)/$(@:f)
+
.ENDIF