summaryrefslogtreecommitdiff
path: root/sysui/desktop/debian
diff options
context:
space:
mode:
authorIvo Hinkelmann <ihi@openoffice.org>2006-12-18 15:37:21 +0000
committerIvo Hinkelmann <ihi@openoffice.org>2006-12-18 15:37:21 +0000
commitd2152930850ea0b2513580c8a228c6b47d3729f0 (patch)
tree9ddb2efceafebff4b0fdf99ea982daa5b0cbd1ee /sysui/desktop/debian
parent8940a87f16f78014f3469f016eb3de67590ae759 (diff)
INTEGRATION: CWS jl46 (1.15.16); FILE MERGED
2006/12/12 21:02:16 ihi 1.15.16.5: Extension support for solaris 2006/12/04 15:52:24 jl 1.15.16.4: RESYNC: (1.15-1.16); FILE MERGED 2006/11/27 15:53:38 ihi 1.15.16.3: #i69173# Systemintegration for Extensions 2006/11/16 18:52:26 ihi 1.15.16.2: #i69173# Systemintegration for Extensions 2006/10/17 12:56:06 ihi 1.15.16.1: #i69173# Systemintegration for Extensions
Diffstat (limited to 'sysui/desktop/debian')
-rw-r--r--sysui/desktop/debian/makefile.mk25
1 files changed, 19 insertions, 6 deletions
diff --git a/sysui/desktop/debian/makefile.mk b/sysui/desktop/debian/makefile.mk
index 20a5a60156f0..3acdf59833f1 100644
--- a/sysui/desktop/debian/makefile.mk
+++ b/sysui/desktop/debian/makefile.mk
@@ -4,9 +4,9 @@
#
# $RCSfile: makefile.mk,v $
#
-# $Revision: 1.16 $
+# $Revision: 1.17 $
#
-# last change: $Author: kz $ $Date: 2006-11-08 11:54:50 $
+# last change: $Author: ihi $ $Date: 2006-12-18 16:37:21 $
#
# The Contents of this file are made available subject to
# the terms of GNU Lesser General Public License Version 2.1.
@@ -55,7 +55,7 @@ TARGET=debian
# GNOME does not like icon names with more than one '.'
ICONPREFIX = $(UNIXFILENAME:s/.//g)
-LAUNCHERLIST = writer calc draw impress math base printeradmin
+LAUNCHERLIST = writer calc draw impress math base printeradmin extension
LAUNCHERDEPN = $(foreach,i,$(LAUNCHERLIST) $(UNIXFILENAME)-$i.desktop)
LAUNCHERDIR = $(shell cd $(MISC)$/$(TARGET); pwd)
@@ -81,7 +81,8 @@ MIMELIST = \
oasis-formula \
oasis-master-document \
oasis-database \
- oasis-web-template
+ oasis-web-template \
+ extension
MIMEICONLIST = \
oasis-text \
@@ -106,7 +107,8 @@ MIMEICONLIST = \
presentation-template \
formula \
master-document \
- database
+ database \
+ extension
GNOMEMIMEDEPN = ../mimetypes/{$(MIMELIST)}.keys ../mimetypes/openoffice.mime
KDEMIMEDEPN = ../mimetypes/{$(MIMELIST)}.desktop
@@ -135,6 +137,8 @@ DEBFILE=$(PKGDIR)/$(PKGNAME)_$(PKGVERSION)-$(PKGREV)_all.deb
DEBDEPN = \
$(MISC)/$(TARGET)/$(DEBFILE:f)/etc/$(UNIXFILENAME) \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/soffice \
+ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/unopkg_gui \
+ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/unopkg \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/$(UNIXFILENAME) \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/$(UNIXFILENAME)-printeradmin \
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/lib/menu/$(PKGNAME) \
@@ -221,7 +225,7 @@ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/application-registry/$(UNIXFILENAME).ap
@$(MKDIRHIER) $(@:d)
@echo Creating GNOME .applications file ..
@echo ---------------------------------
- @cat ../mimetypes/openoffice.applications | tr -d "\015" | sed -e "s/openoffice/$(UNIXFILENAME)/" -e "s/%PRODUCTNAME/$(LONGPRODUCTNAME)/" > $@
+ @cat ../mimetypes/openoffice.applications | tr -d "\015" | sed -e "s/OFFICENAME/$(UNIXFILENAME)/" -e "s/%PRODUCTNAME/$(LONGPRODUCTNAME)/" > $@
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/share/mime/packages/openoffice.org.xml : $(COMMONMISC)$/desktopshare/openoffice.org.xml
@$(MKDIRHIER) $(@:d)
@@ -234,6 +238,7 @@ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/$(UNIXFILENAME) : ../share/openoffice.sh
@cat $< | tr -d "\015" | sed -e "s/%PREFIX/$(UNIXFILENAME)/g" > $@
@chmod a+x $@
+
$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/$(UNIXFILENAME)-printeradmin : ../share/printeradmin.sh
@$(MKDIRHIER) $(@:d)
@cat $< | tr -d "\015" | sed -e "s/%PREFIX/$(UNIXFILENAME)/g" > $@
@@ -243,6 +248,14 @@ $(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/soffice :
@$(MKDIRHIER) $(@:d)
@ln -sf /etc/$(UNIXFILENAME)/program/soffice $@
+$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/unopkg_gui :
+ @$(MKDIRHIER) $(@:d)
+ @ln -sf /etc/$(UNIXFILENAME)/program/unopkg_gui $@
+
+$(MISC)/$(TARGET)/$(DEBFILE:f)/usr/bin/unopkg :
+ @$(MKDIRHIER) $(@:d)
+ @ln -sf /etc/$(UNIXFILENAME)/program/unopkg $@
+
$(MISC)/$(TARGET)/$(DEBFILE:f)/etc/$(UNIXFILENAME) :
@$(MKDIRHIER) $(@:d)
@ln -sf /opt/openoffice.org$(PRODUCTVERSION) $@