summaryrefslogtreecommitdiff
path: root/package/util/makefile.mk
diff options
context:
space:
mode:
authorMartin Gallwey <mtg@openoffice.org>2000-11-13 12:38:03 +0000
committerMartin Gallwey <mtg@openoffice.org>2000-11-13 12:38:03 +0000
commitdb4e8a77ce6ad9a7f742574a6c01121675bd8c9c (patch)
tree5db30bcc8150595546941efc88ed432c6c7d3fb1 /package/util/makefile.mk
parente1f02829a365c86e711bdc8141c8308e60bcfd45 (diff)
Initial Revision :D
Diffstat (limited to 'package/util/makefile.mk')
-rw-r--r--package/util/makefile.mk118
1 files changed, 118 insertions, 0 deletions
diff --git a/package/util/makefile.mk b/package/util/makefile.mk
new file mode 100644
index 000000000000..6c42e80186fb
--- /dev/null
+++ b/package/util/makefile.mk
@@ -0,0 +1,118 @@
+#*************************************************************************
+#
+# $RCSfile: makefile.mk,v $
+#
+# $Revision: 1.1 $
+#
+# last change: $Author: mtg $ $Date: 2000-11-13 13:38:03 $
+#
+# The Contents of this file are made available subject to the terms of
+# either of the following licenses
+#
+# - GNU Lesser General Public License Version 2.1
+# - Sun Industry Standards Source License Version 1.1
+#
+# Sun Microsystems Inc., October, 2000
+#
+# GNU Lesser General Public License Version 2.1
+# =============================================
+# Copyright 2000 by Sun Microsystems, Inc.
+# 901 San Antonio Road, Palo Alto, CA 94303, USA
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License version 2.1, as published by the Free Software Foundation.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+#
+# Sun Industry Standards Source License Version 1.1
+# =================================================
+# The contents of this file are subject to the Sun Industry Standards
+# Source License Version 1.1 (the "License"); You may not use this file
+# except in compliance with the License. You may obtain a copy of the
+# License at http://www.openoffice.org/license.html.
+#
+# Software provided under this License is provided on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
+# WITHOUT LIMITATION, WARRANTIES THAT THE SOFTWARE IS FREE OF DEFECTS,
+# MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE, OR NON-INFRINGING.
+# See the License for the specific provisions governing your rights and
+# obligations concerning the Software.
+#
+# The Initial Developer of the Original Code is: Sun Microsystems, Inc.
+#
+# Copyright: 2000 by Sun Microsystems, Inc.
+#
+# All Rights Reserved.
+#
+# Contributor(s): _______________________________________
+#
+#
+#
+#*************************************************************************
+
+PRJ=..
+
+PRJNAME=package
+TARGET=package
+
+# --- Settings -----------------------------------------------------
+
+.INCLUDE : settings.mk
+
+# --- General ----------------------------------------------------
+
+LIB1TARGET= $(SLB)$/package.lib
+LIB1FILES= \
+ $(SLB)$/zipapi.lib \
+
+# --- Shared-Library -----------------------------------------------
+
+SHL1TARGET= package$(UPD)$(DLLPOSTFIX)
+SHL1IMPLIB= _ipackage
+
+SHL1STDLIBS= \
+ $(TOOLSLIB) \
+ $(VOSLIB) \
+ $(CPPULIB) \
+ $(CPPUHELPERLIB)\
+ $(COMPHELPERLIB)\
+ $(RTLLIB) \
+ $(SALLIB) \
+ $(UNOTOOLSLIB) \
+ $(ZLIB3RDLIB)
+
+SHL1DEF= $(MISC)$/$(SHL1TARGET).def
+SHL1LIBS= $(LIB1TARGET)
+
+# --- Def-File ---------------------------------------------------------
+
+DEF1NAME =$(SHL1TARGET)
+DEF1DEPN =$(MISC)$/$(SHL1TARGET).flt
+DEFLIB1NAME =package
+DEF1DES =Package Lib
+
+
+# --- Targets ----------------------------------------------------------
+
+.INCLUDE : target.mk
+
+# --- Filter ----------------------------------------------------------
+
+$(MISC)$/$(SHL1TARGET).flt: makefile.mk
+.IF "$(GUI)"=="WNT"
+ +echo _CT? > $@
+.ENDIF
+ +echo _CTA >> $@
+ +echo sXML_ >> $@
+
+