summaryrefslogtreecommitdiff
path: root/dmake/configure.in
diff options
context:
space:
mode:
authorSander Vesik <svesik@openoffice.org>2004-04-21 13:10:00 +0000
committerSander Vesik <svesik@openoffice.org>2004-04-21 13:10:00 +0000
commit5d2003fe8a73961749dfa88718fa102014272e6a (patch)
tree94b59f0e8eeac9295be6b096f36c790ff6865529 /dmake/configure.in
parent45ab78c4a333ae3db590969f0b01cab3ec925a98 (diff)
INTEGRATION: CWS ooo20040329 (1.20.14); FILE MERGED
2004/03/19 12:36:41 waratah 1.20.14.1: #i13620# allow configure to pick up on types defined by AIX and also allow AIX to work in configure
Diffstat (limited to 'dmake/configure.in')
-rwxr-xr-xdmake/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/dmake/configure.in b/dmake/configure.in
index 05f2ef0240d3..ca7b4c5392f3 100755
--- a/dmake/configure.in
+++ b/dmake/configure.in
@@ -37,6 +37,12 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_OFF_T
AC_TYPE_SIZE_T
+AC_CHECK_TYPES(int8)
+AC_CHECK_TYPES(uint8)
+AC_CHECK_TYPES(int16)
+AC_CHECK_TYPES(uint16)
+AC_CHECK_TYPES(int32)
+AC_CHECK_TYPES(uint32)
AC_HEADER_TIME
AC_CHECK_SIZEOF(short, 2)
AC_CHECK_SIZEOF(int, 4)
@@ -111,6 +117,9 @@ case "$_os" in
"GNU")
OS_VERSION=linux
;;
+ "AIX")
+ OS_VERSION=sysvr4
+ ;;
*)
AC_MSG_ERROR([$_os operating system is not suitable to build dmake!])
;;