summaryrefslogtreecommitdiff
path: root/dmake/configure.in
diff options
context:
space:
mode:
authorKen Foskey <waratah@openoffice.org>2002-10-07 11:09:50 +0000
committerKen Foskey <waratah@openoffice.org>2002-10-07 11:09:50 +0000
commit0da71a9e866a9eb8770cc55844eb70bde9e1d926 (patch)
tree82e3fa5d0e5265c0810f153fa2bd8c4af64f9ba1 /dmake/configure.in
parent8607f77cbfbd07b115798360f59b0beaeb36d288 (diff)
dmake: Add gnu hurd and some additional header checks, and the cygwin makefiles
Diffstat (limited to 'dmake/configure.in')
-rwxr-xr-xdmake/configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/dmake/configure.in b/dmake/configure.in
index 6c5e0b669d47..85c9184015f9 100755
--- a/dmake/configure.in
+++ b/dmake/configure.in
@@ -31,7 +31,7 @@ dnl Initialize libtool
dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/types.h sys/stat.h unistd.h errno.h)
+AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/types.h sys/stat.h unistd.h errno.h utime.h spawn.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -55,6 +55,9 @@ if test `echo $_os | $AWK -F_ '{ print $1 }'` = "CYGWIN"; then
_os="WINNT"
fi
+
+## The following allows like systems to share settings this is not meant to
+## Imply that these OS are the same thing.
case "$_os" in
"SunOS")
OS_VERSION=solaris
@@ -83,6 +86,9 @@ case "$_os" in
"IRIX64")
OS_VERSION=sysvr4
;;
+ "GNU")
+ OS_VERSION=linux
+ ;;
*)
AC_MSG_ERROR([$_os operating system is not suitable to build dmake!])
;;
@@ -98,8 +104,7 @@ AM_CONFIG_HEADER(config.h)
AC_OUTPUT(Makefile unix/Makefile startup/Makefile startup/unix/Makefile \
startup/unix/linux/Makefile startup/unix/solaris/Makefile \
startup/unix/macosx/Makefile startup/unix/sysvr4/Makefile \
- dmakeroot.h )
-### startup/unix/cygwin/Makefile )
+ startup/unix/cygwin/Makefile dmakeroot.h )
dnl ******************************
dnl *** output the whole stuff ***