summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-02-21 12:47:34 +0200
committerTor Lillqvist <tml@iki.fi>2012-02-21 14:19:49 +0200
commitf9a5c4cbc275df6dd5a3b31323b1d00343e8e4f0 (patch)
tree77cd7fdbba6e615f77a31844369fb23f918075be /configure.in
parentefa6a5f0444ab2299f91608f4a5b78848814458e (diff)
More --disable-database-connectivity work, still experimental
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 303b5c876de9..12ce546a9db5 100644
--- a/configure.in
+++ b/configure.in
@@ -384,7 +384,7 @@ AC_ARG_ENABLE(ext-barcode,
AC_ARG_ENABLE(database-connectivity,
AS_HELP_STRING([--disable-database-connectivity],
- [Disable various database connectivity.])
+ [Disable various database connectivity. Work in progress, don't use.])
)
AC_ARG_ENABLE(ext-diagram,
@@ -2040,9 +2040,13 @@ if test -z "$enable_database_connectivity"; then
fi
fi
+DISABLE_DBCONNECTIVITY=''
if test "$enable_database_connectivity" = yes; then
BUILD_TYPE="$BUILD_TYPE DBCONNECTIVITY"
+else
+ DISABLE_DBCONNECTIVITY='TRUE'
fi
+AC_SUBST(DISABLE_DBCONNECTIVITY)
dnl ===================================================================
dnl Extra check for Windows. Cygwin builds need gcc to build dmake