summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2012-08-26 11:30:14 +0200
committerTomas Chvatal <tchvatal@suse.cz>2012-08-26 11:30:14 +0200
commit061652ff712da51b9f4c9efbc205869316149f70 (patch)
tree26248607dfc698db35334abae00e0ac6d19315df /configure.in
parente3e68199a47c694b60de754930dd2fe5d43533bb (diff)
Update desc of mergelib configure option
Also do not be fatal on clash with binfilter and just warn the user that mergelib was disabled in favor of binfilter if he has both enabled. Change-Id: I3b683a948e00b1134c10881c5ec442e6380f2822
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 86a1ceeb072d..7d7ec8bc8533 100644
--- a/configure.in
+++ b/configure.in
@@ -660,8 +660,8 @@ dnl ---------- *** ----------
AC_ARG_ENABLE(mergelibs,
AS_HELP_STRING([--enable-mergelibs],
- [Enables linking of big, merged, library.
- Still somehow experimental. Tested only for Linux and Android.])
+ [Enables linking of big, merged, library. Experimental feature tested
+ only on Linux and Android.])
)
AC_ARG_ENABLE(graphite,
@@ -12075,13 +12075,15 @@ AC_MSG_CHECKING([whether to create huge library])
MERGELIBS=
if test $enable_mergelibs = yes; then
if test $WITH_BINFILTER = YES; then
- AC_MSG_ERROR([--enable-mergelibs conflicts with --enable-binfilter. It would need fixing.])
- fi
- if test $_os != Linux -a $_os != Android; then
- add_warning "--enable-mergelibs is not tested for this platform"
+ add_warining "--enable-mergelibs conflicts with --enable-binfilter. Disabling mergelibs."
+ AC_MSG_RESULT([no])
+ else
+ if test $_os != Linux -a $_os != Android; then
+ add_warning "--enable-mergelibs is not tested for this platform"
+ fi
+ MERGELIBS="TRUE"
+ AC_MSG_RESULT([yes])
fi
- MERGELIBS="TRUE"
- AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
fi