summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2012-11-05 14:34:27 +0100
committerPetr Mladek <pmladek@suse.cz>2012-11-05 14:34:27 +0100
commitef15a5a4acd3174752484c6aeb570d4d6444b645 (patch)
tree3d1d5b58f85737aa46241aea4c4dabea520cecc2 /configure.in
parenta1b0ce05e851e9724c046888a01869eddf9e9db2 (diff)
parentc309ce0227a14330094191c1ef15fa00899defcb (diff)
Merge remote-tracking branch 'origin/libreoffice-3-6-3' into suse-3.6
Conflicts: desktop/source/app/sofficemain.cxx instsetoo_native/util/openoffice.lst solenv/inc/minor.mk Change-Id: I3e9510067c7173f6c71368e70ba6dfe168c5318e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7f144130a5ed..2f01827d2db4 100644
--- a/configure.in
+++ b/configure.in
@@ -1837,6 +1837,20 @@ AC_ARG_WITH(intro-progressbar-frame-color,
Usage: --with-intro-progressbar-frame-color=207,208,211
],,)
+AC_ARG_WITH(intro-progressbar-text-color,
+ AS_HELP_STRING([--with-intro-progressbar-text-color],
+ [Set color of progress bar text on intro screen. Comma separated RGB values in decimal format.])
+ [
+ Usage: --with-intro-progressbar-text-color=207,208,211
+],,)
+
+AC_ARG_WITH(intro-progressbar-text-baseline,
+ AS_HELP_STRING([--with-intro-progressbar-text-baseline],
+ [Set vertical position of progress bar text on intro screen. Value in decimal format.])
+ [
+ Usage: --with-intro-progressbar-text-baseline=250
+],,)
+
AC_ARG_WITH(flat-logo-svg,
[ --with-flat-logo-svg Allows specification of the flat Logo SVG.
@@ -11408,6 +11422,28 @@ else
fi
AC_SUBST(PROGRESSFRAMECOLOR)
+AC_MSG_CHECKING([for custom 'intro' progress text color])
+PROGRESSTEXTCOLOR=
+if test -z "$with_intro_progressbar_text_color"; then
+ PROGRESSTEXTCOLOR="255,255,255"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSTEXTCOLOR="$with_intro_progressbar_text_color"
+ AC_MSG_RESULT([$PROGRESSTEXTCOLOR])
+fi
+AC_SUBST(PROGRESSTEXTCOLOR)
+
+AC_MSG_CHECKING([for custom 'intro' progress text baseline])
+PROGRESSTEXTBASELINE=
+if test -z "$with_intro_progressbar_text_baseline"; then
+ PROGRESSTEXTBASELINE="287"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSTEXTBASELINE="$with_intro_progressbar_text_baseline"
+ AC_MSG_RESULT([$PROGRESSTEXTBASELINE])
+fi
+AC_SUBST(PROGRESSTEXTBASELINE)
+
AC_MSG_CHECKING([for alternative branding images directory])
INTRO_BITMAP=
ABOUT_BACKGROUND_SVG=