summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2012-08-26 11:30:14 +0200
committerMatúš Kukan <matus.kukan@gmail.com>2012-08-30 16:47:15 +0200
commit8d3ea9985e6defd2b6522b755a29c6406c8cdcb6 (patch)
treeb7d44892f77830d105085688fe50d082c77ea022 /configure.in
parent132ffae17678df9c10d31dd3ae7540254a58dbf0 (diff)
Update desc of mergelib configure option
Also do not be fatal on clash with binfilter and just warn the user that mergelib was disabled in favor of binfilter if he has both enabled. Change-Id: I3b683a948e00b1134c10881c5ec442e6380f2822 Signed-off-by: Matúš Kukan <matus.kukan@gmail.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a080a0261b29..276d84413f0e 100644
--- a/configure.in
+++ b/configure.in
@@ -561,7 +561,8 @@ dnl ---------- *** ----------
AC_ARG_ENABLE(mergelibs,
AS_HELP_STRING([--enable-mergelibs],
- [Enables linking of big merged library used for better performance.])
+ [Enables linking of big, merged, library. Experimental feature tested
+ only on Linux and Android.])
)
AC_ARG_ENABLE(graphite,
@@ -11648,9 +11649,17 @@ fi
# ===================================================================
AC_MSG_CHECKING([whether to create a big library for better performance])
MERGELIBS=
-if test "$enable_mergelibs" = "yes"; then
- MERGELIBS="TRUE"
- AC_MSG_RESULT([yes])
+if test $enable_mergelibs = yes; then
+ if test $WITH_BINFILTER = YES; then
+ add_warning "--enable-mergelibs conflicts with --enable-binfilter. Disabling mergelibs."
+ AC_MSG_RESULT([no])
+ else
+ if test $_os != Linux -a $_os != Android; then
+ add_warning "--enable-mergelibs is not tested for this platform"
+ fi
+ MERGELIBS="TRUE"
+ AC_MSG_RESULT([yes])
+ fi
else
AC_MSG_RESULT([no])
fi