summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-04-03 08:58:05 +0200
committerStephan Bergmann <sbergman@redhat.com>2012-04-03 08:58:05 +0200
commit844b4520a9f0879d7b756654cef8fdbaa03a9000 (patch)
tree83e0d223aa6306bd0734a4652b35294e4ac6eaf7 /configure.in
parentd5c5800bffe97911497a0603567417dea15f295f (diff)
--enable-ext-languagetool requires --with-java
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 067fa4f57b1f..2158d03dbbab 100644
--- a/configure.in
+++ b/configure.in
@@ -435,7 +435,7 @@ AC_ARG_ENABLE(ext-hunart,
AC_ARG_ENABLE(ext-languagetool,
AS_HELP_STRING([--enable-ext-languagetool],
- [Enable the LanguageTool extension.])
+ [Enable the LanguageTool extension. Does not work --without-java.])
)
AC_ARG_ENABLE(ext-mysql-connector,
@@ -9604,6 +9604,9 @@ dnl Test whether to include LanguageTool extension
dnl ===================================================================
AC_MSG_CHECKING([for LanguageTool extension integration])
if test "x$enable_ext_languagetool" = "xyes" -a "x$enable_extension_integration" != "xno"; then
+ if test -z "$SOLAR_JAVA"; then
+ AC_MSG_ERROR([--enable_ext_languagetool requires --with-java])
+ fi
BUILD_TYPE="$BUILD_TYPE LANGUAGETOOL"
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_LANGUAGETOOL"
AC_MSG_RESULT([yes])