summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomáš Chvátal <tchvatal@suse.cz>2012-05-04 14:52:51 +0200
committerTomáš Chvátal <tchvatal@suse.cz>2012-05-04 14:56:42 +0200
commitffc198fb645f13a14e64eeb4e7067c42e97f4b63 (patch)
treeecd900e2b17a20fee23c9defb1f948ad01715dae /configure.in
parent5794a9403059796a855c873f0e0f19f6cdbb2646 (diff)
Provide again wrongly removed gallaxy theme.
Also sort all the others alphabetically. By the default the provided themes are same as on 3.5, otherwise user can specify each of the available ones. This avoids use of --with-theme=default which then produces warning "no such file or directory default" by using the proper theme name (ie. galaxy) which does not produce this. There is no visible difference on: --with-themes=galaxy or --with-themes=default Change-Id: I I1a6409f55fdfdff6a19781b25627dcb7682b0fb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 5abb680e3499..c79ee5ddc837 100644
--- a/configure.in
+++ b/configure.in
@@ -975,7 +975,7 @@ AC_ARG_WITH(vba-package-format,
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
- Possible choices: *default, *crystal, *hicontrast, *oxygen, *tango, classic, industrial, human.]),
+ Possible choices: classic, crystal, *default (galaxy), *hicontrast, human, industrial, *oxygen, *tango.]),
,)
AC_ARG_WITH(helppack-integration,
@@ -9606,15 +9606,15 @@ dnl ===================================================================
dnl Test which themes to include
dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
-# if none given, use all available themes
+# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
- with_theme="crystal hicontrast human oxygen tango"
+ with_theme="crystal default hicontrast oxygen tango"
fi
WITH_THEMES=""
for theme in $with_theme; do
case $theme in
- classic|crystal|galaxy|hicontrast|human|industrial|oxygen|tango) : ;;
+ classic|crystal|default|hicontrast|human|industrial|oxygen|tango) : ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
esac
WITH_THEMES="$WITH_THEMES $theme"