summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2012-05-12 00:30:32 +0100
committerCaolán McNamara <caolanm@redhat.com>2012-05-12 00:30:32 +0100
commit78fcdec5b062161493511c0e898051478962f490 (patch)
tree9cb32b4d79856570fdcc4eed3287ea4f469239f5 /configure.in
parent03ca37a3034027e9ef4cf80814994007fd595a95 (diff)
set better mingw32 icu defaults
Change-Id: I57b6d24c3a367ac711231046bada78619a13ab16
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 1d84260c0a15..71b8f1f0b772 100644
--- a/configure.in
+++ b/configure.in
@@ -7712,6 +7712,16 @@ if test "$with_system_icu" = "yes"; then
ICU_MAJOR=`echo $ICU_VERSION | cut -d"." -f1`
ICU_MINOR=`echo $ICU_VERSION | cut -d"." -f2`
ICU_MICRO=`echo $ICU_VERSION | cut -d"." -f3`
+ if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4"; then
+ ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
+ else
+ ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
+ fi
+ if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "9"; then
+ ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
+ else
+ ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
+ fi
if test "$ICU_MAJOR" -ge "4"; then
AC_MSG_RESULT([OK, $ICU_VERSION])
@@ -7761,16 +7771,6 @@ You can use --with-system-icu-for-build=force to use it anyway.])
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\'gencmn\' not found in \$PATH, install the icu development tool \'gencmn\'])
fi
- if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4"; then
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
- else
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
- fi
- if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "9"; then
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
- else
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
- fi
fi
libo_MINGW_CHECK_DLL([ICUDATA], [icudata][$ICU_MAJOR][$ICU_MINOR])