summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-04-24 22:30:03 +0300
committerTor Lillqvist <tml@iki.fi>2012-04-24 23:56:51 +0300
commite5143062887093037cab8f936288af8408576ea8 (patch)
tree8aaeb0fedb9509737d7c62a9939eae0db7e8f5d7 /configure.in
parentf024b6804d216c4eee2ebd09074eff2ca1984997 (diff)
Visibility doesn't seem to work as we want in Apple's Clang
Or maybe it's the Mach-O object file format that lacks the functionality? Anyway, let's try to manage without visibility then.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5618f1e46e3e..9fcc1f85284e 100644
--- a/configure.in
+++ b/configure.in
@@ -4540,6 +4540,15 @@ if test "$GCC" = "yes"; then
CFLAGS="$CFLAGS -Werror -fvisibility=hidden"
AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_VISIBILITY_FEATURE=TRUE ],[])
CFLAGS=$save_CFLAGS
+
+ if test "$COM_GCC_IS_CLANG" = TRUE -a $_os = Darwin; then
+ # It seems that with Apple's Clang, visibility doesn't work as
+ # we would want at least in the connectivity and dbaccess
+ # modules. This might be because of something peculiar in
+ # those modules? Whatever.
+ HAVE_GCC_VISIBILITY_FEATURE=
+ fi
+
if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE"; then
AC_MSG_RESULT([yes])
else