summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-04-25 10:25:29 +0300
committerTor Lillqvist <tlillqvist@suse.com>2012-04-25 10:26:05 +0300
commitd6b2189fee1df979dfee53ac3824f101278facdf (patch)
tree82d723887f9d22fa42b65c3a2342df9c6d06d8ac /configure.in
parentee242df844d1a2b85e0d7b86dbdb8bf3643fc74f (diff)
Fix test syntax error: integer expression expected
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 9fcc1f85284e..0b0ceda45271 100644
--- a/configure.in
+++ b/configure.in
@@ -2574,7 +2574,7 @@ HAVE_GCC_FINLINE_LIMIT=
HAVE_GCC_FNO_INLINE=
if test "$GCC" = "yes"; then
AC_MSG_CHECKING([whether $CC supports -ggdb2])
- if test -n "$CLANGVER" -a "$CLANGVER" -le 30100; then
+ if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
# Option just ignored and silly warning that isn't a real
# warning printed
:
@@ -2591,7 +2591,7 @@ if test "$GCC" = "yes"; then
fi
AC_MSG_CHECKING([whether $CC supports -finline-limit=0])
- if test -n "$CLANGVER" -a "$CLANGVER" -le 30100; then
+ if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
# As above
:
else
@@ -2607,7 +2607,7 @@ if test "$GCC" = "yes"; then
fi
AC_MSG_CHECKING([whether $CC supports -fno-inline])
- if test -n "$CLANGVER" -a "$CLANGVER" -le 30100; then
+ if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
# Ditto
:
else
@@ -4784,7 +4784,7 @@ HAVE_GCC_FNO_DEFAULT_INLINE=
HAVE_GCC_FNO_ENFORCE_EH_SPECS=
if test "$GCC" = "yes"; then
AC_MSG_CHECKING([whether $CXX supports -fno-default-inline])
- if test -n "$CLANGVER" -a "$CLANGVER" -le 30100; then
+ if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
# Option just ignored and silly warning that isn't a real
# warning printed
:
@@ -4803,7 +4803,7 @@ if test "$GCC" = "yes"; then
fi
AC_MSG_CHECKING([whether $CXX supports -fno-enforce-eh-specs])
- if test -n "$CLANGVER" -a "$CLANGVER" -le 30100; then
+ if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
# As above
:
else