summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-04-15 15:38:47 +0200
committerTor Lillqvist <tml@iki.fi>2012-04-15 15:38:47 +0200
commit10acafe29e02a4fc307c085f7b550bd2281f482c (patch)
treecd2cf3abef7072747b7e6b25faeace39226b135c /configure.in
parentf62c863f97fa2e848be0c3231596301195080694 (diff)
Guard against lack of pkg-config in one more place
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bac686636475..01b86c285dbd 100644
--- a/configure.in
+++ b/configure.in
@@ -6294,7 +6294,10 @@ if test $enable_python = system; then
python_version=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('VERSION'));"`
python_libs=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('LIBS'));"`
python_libdir=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('LIBDIR'));"`
- if $PKG_CONFIG --exists python-$python_version; then
+ if test -z "$PKG_CONFIG"; then
+ PYTHON_CFLAGS="-I$python_include"
+ PYTHON_LIBS="-L$python_libdir -lpython$python_version $python_libs"
+ elif $PKG_CONFIG --exists python-$python_version; then
PYTHON_CFLAGS="`$PKG_CONFIG --cflags python-$python_version`"
PYTHON_LIBS="`$PKG_CONFIG --libs python-$python_version` $python_libs"
else