summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-06-01 10:59:11 +0200
committerDavid Tardon <dtardon@redhat.com>2012-06-01 10:59:11 +0200
commite27f66040bec04e6f139bac80c128a88cbf877dd (patch)
treeec014d7fe4c3259f713a2f921287bcd5b36e4b7d /configure.in
parentb42013ee093b7f91f91ec6ca9c3b3c08fe55b530 (diff)
only check for ext. headers when building with X11
Change-Id: Ia37e0cbda71fb10be269bd47657b512ae07ea796
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 293f1c5d29f4..04df9819cfa6 100644
--- a/configure.in
+++ b/configure.in
@@ -8060,16 +8060,20 @@ if test "$WANT_X11" = "yes"; then
dnl ===================================================================
AC_CHECK_HEADERS(X11/Composite.h,[],[AC_MSG_ERROR([Xt headers not found])],
[#include <X11/Intrinsic.h>])
-fi
-AC_MSG_CHECKING([whether to use internal X11 extensions headers])
-if test "$with_system_xextensions_headers" != "no"; then
- AC_MSG_RESULT([no])
- AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
- [#include <X11/extensions/shape.h>])
-else
- AC_MSG_RESULT([yes])
- BUILD_TYPE="$BUILD_TYPE X11_EXTENSIONS"
+ dnl ===================================================================
+ dnl Check for extension headers
+ dnl ===================================================================
+ AC_MSG_CHECKING([whether to use internal X11 extensions headers])
+ if test "$with_system_xextensions_headers" != "no"; then
+ AC_MSG_RESULT([no])
+ AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
+ [#include <X11/extensions/shape.h>])
+ else
+ AC_MSG_RESULT([yes])
+ BUILD_TYPE="$BUILD_TYPE X11_EXTENSIONS"
+ fi
+
fi
dnl ===================================================================