summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-05-14 08:15:32 +0200
committerDavid Tardon <dtardon@redhat.com>2012-05-14 08:27:32 +0200
commitdd49c193de9c4515335ad4a29778ceff225e3c38 (patch)
tree26957750e4e080fe3d6adb8fddec25f371a84251 /configure.in
parent5a5d80ce5483696e0b05c31a0c4134c8ae4b82eb (diff)
make build work again with older ICU
The recent addition of Hebrew line breaking rules apparently does not work with genbrk from ICU 4.6. Maybe we should just require 4.x (where x is the first version where it is implemented) as minimum ICU version? IMHO it would be better than this insane (and fragile) filtering... Change-Id: Ia2adad3621fa7a2f319a07fb569b1f1c1eb6db7c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ddf47e8de005..3659e5c74833 100644
--- a/configure.in
+++ b/configure.in
@@ -7691,6 +7691,8 @@ ICU_MINOR=
ICU_MICRO=
ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
+ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="YES"
+ICU_RECLASSIFIED_HEBREW_LETTER="YES"
AC_MSG_CHECKING([which icu to use])
if test "$with_system_icu" = "yes"; then
AC_MSG_RESULT([external])
@@ -7760,6 +7762,10 @@ You can use --with-system-icu-for-build=force to use it anyway.])
else
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
fi
+ if test "$ICU_MAJOR" -eq 4 -a "$ICU_MINOR" -le 6; then
+ ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="NO"
+ ICU_RECLASSIFIED_HEBREW_LETTER="NO"
+ fi
fi
libo_MINGW_CHECK_DLL([ICUDATA], [icudata][$ICU_MAJOR][$ICU_MINOR])
@@ -7779,6 +7785,8 @@ AC_SUBST(ICU_MAJOR)
AC_SUBST(ICU_MINOR)
AC_SUBST(ICU_MICRO)
AC_SUBST(ICU_RECLASSIFIED_CLOSE_PARENTHESIS)
+AC_SUBST([ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER])
+AC_SUBST([ICU_RECLASSIFIED_HEBREW_LETTER])
AC_SUBST(ICU_RECLASSIFIED_PREPEND_SET_EMPTY)
AC_SUBST([MINGW_ICUDATA_DLL])
AC_SUBST([MINGW_ICUI18N_DLL])