summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-05-14 11:44:12 +0300
committerTor Lillqvist <tlillqvist@suse.com>2012-05-14 11:44:47 +0300
commitbae852548bb6559ae16402400ff4c63c225008f7 (patch)
tree97fca78c1519e18d7a826b15c5666d4e6b0e2a32 /configure.in
parent1d32c56f36adbd0d5801f0fedec3111011ea4d65 (diff)
No CUPS for Android or iOS
Change-Id: I34b65232b11111fef6473577decc0849d3443fce
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3659e5c74833..5038c03f46d1 100644
--- a/configure.in
+++ b/configure.in
@@ -3633,10 +3633,18 @@ dnl ===================================================================
if test "$enable_cups" = "no"; then
test_cups=no
ENABLE_CUPS="NO"
+elif test "$enable_cups" = "yes"; then
+ if test $_os = iOS -o $_os = Android; then
+ AC_MSG_ERROR([CUPS makes no sense for $_os])
+ fi
+ ENABLE_CUPS="YES"
+elif test $_os = iOS -o $_os = Android; then
+ ENABLE_CUPS=NO
else
ENABLE_CUPS="YES"
fi
AC_SUBST(ENABLE_CUPS)
+
if test "$test_cups" = "yes"; then
AC_MSG_CHECKING([whether cups support is present])
AC_CHECK_LIB([cups], [cupsPrintFiles], [:])