summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2012-05-31 15:48:15 +0200
committerMatúš Kukan <matus.kukan@gmail.com>2012-05-31 15:48:42 +0200
commit6a491cbe8f86e7ce57e0281bf45d74c628ef7956 (patch)
tree5ca159bf0e09904048c6563de9f00c7930ea52f5 /configure.in
parent631c25c2ea32e6a61f6dda519bab0fa985885ee2 (diff)
fix SCPDEFS for --disable-activex
Change-Id: Id20f7294e2bf00cf1a980cb137b51a107ef698e7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 2 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index c83482930225..970603332ac5 100644
--- a/configure.in
+++ b/configure.in
@@ -601,11 +601,6 @@ AC_ARG_ENABLE(epm,
useless for large scale package building.])
)
-AC_ARG_ENABLE(activex_component,
- AS_HELP_STRING([--disable-activex-component],
- [Remove support for ActiveX embedding of LibreOffice.])
-)
-
AC_ARG_ENABLE(odk,
AS_HELP_STRING([--disable-odk],
[LibreOffice includes an ODK, office development kit which some packagers may
@@ -2556,6 +2551,7 @@ if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([whether to use ActiveX])
if test "$enable_activex" = "yes" -o "$enable_activex" = "TRUE" -o "$enable_activex" = ""; then
DISABLE_ACTIVEX=""
+ SCPDEFS="$SCPDEFS -DWITH_ACTIVEX_COMPONENT"
AC_MSG_RESULT([yes])
else
DISABLE_ACTIVEX="TRUE"
@@ -10476,22 +10472,7 @@ else
fi
AC_SUBST(ENABLE_SILENT_MSI)
-dnl ===================================================================
-dnl Test whether to enable ActiveX embedding
-dnl ===================================================================
-if test "$_os" = "WINNT" -a "$WITH_MINGW" != yes; then
- AC_MSG_CHECKING([whether to enable ActiveX embedding of LibreOffice components])
- if test "$enable_activex_component" = "yes" -o "$enable_activex_component" = "TRUE" -o "$enable_activex_component" = ""; then
- ENABLE_ACTIVEX_COMPONENT="TRUE"
- AC_MSG_RESULT([yes])
- SCPDEFS="$SCPDEFS -DWITH_ACTIVEX_COMPONENT"
- else
- ENABLE_ACTIVEX_COMPONENT=""
- AC_MSG_RESULT([no])
- fi
- AC_SUBST(ENABLE_ACTIVEX_COMPONENT)
- AC_SUBST(SCPDEFS)
-fi
+AC_SUBST(SCPDEFS)
AC_MSG_CHECKING([whether and how to use Xinerama])
if test "$_os" = "Darwin"; then