summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-06-13 18:28:29 +0200
committerJan Holesovsky <kendy@suse.cz>2012-06-18 13:46:51 +0200
commit6873ec8a4eac985eb6fe7bd36d26194ce7fbfcf1 (patch)
treec09d6d0f38c91c336cc34bf7a12a8405cfdf7d1c /configure.in
parentb1250977f873eca6617e32ce4bc7d1d46eea93ad (diff)
mingw: fix check for boost date_time dll
Change-Id: I4a31c215d70e6f8f8fc8a768851315b919fba03e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e61a01f9624b..9cf0baa1d75d 100644
--- a/configure.in
+++ b/configure.in
@@ -7293,7 +7293,12 @@ if test "$with_system_boost" = "yes"; then
AX_BOOST_BASE
AX_BOOST_DATE_TIME
mingw_boost_date_time_dll=`echo $BOOST_DATE_TIME_LIB | sed -e 's/^-l//' -e 's/\.dll$//'`
- libo_MINGW_CHECK_DLL([BOOST_DATE_TIME], [$mingw_boost_date_time_dll])
+ libo_MINGW_TRY_DLL([BOOST_DATE_TIME], [$mingw_boost_date_time_dll])
+ if test -z "$MINGW_BOOST_DATE_TIME_DLL"; then
+ # if not found, try again with 'lib' prefix
+ libo_MINGW_CHECK_DLL([BOOST_DATE_TIME],
+ [lib$mingw_boost_date_time_dll])
+ fi
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE BOOST"