summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-05-17 22:45:04 +0300
committerTor Lillqvist <tml@iki.fi>2012-05-18 09:38:00 +0300
commit6868d84b13a52efe91337f2dccb88e59b9f8d2b7 (patch)
tree9957d331dd1b6a3fc1cbc9729114f04f11015276 /configure.in
parent0ea1287bd9b877524706ae57c2fc32ed54fb062b (diff)
Add generic --with-build-platform-configure-options
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9c23d8a84ec8..510d82aa9a51 100644
--- a/configure.in
+++ b/configure.in
@@ -991,6 +991,9 @@ AC_ARG_WITH(gnu-patch,
[Specify location of GNU patch on Solaris or FreeBSD.]),
,)
+AC_ARG_WITH(build-platform-configure-options,
+ [Specify options for the configure script run for the *build* platform in a cross-compilation])
+
AC_ARG_WITH(gnu-cp,
AS_HELP_STRING([--with-gnu-cp],
[Specify location of GNU cp on Solaris or FreeBSD.]),
@@ -2021,6 +2024,7 @@ AC_ARG_WITH(macosx-version-max-allowed,
dnl ===================================================================
dnl options for stuff used during cross-compilation build
+dnl These are superseded by --with-build-platform-configure-options
dnl ===================================================================
AC_ARG_WITH(system-boost-for-build,
@@ -3472,6 +3476,7 @@ if test "$cross_compiling" = "yes"; then
test -n "$with_system_expat_for_build" && sub_conf_opts="$sub_conf_opts --with-system-expat"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
+ sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
./configure \
--disable-mozilla \
--disable-build-mozilla \