summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-05-14 13:01:58 +0200
committerMichael Stahl <mstahl@redhat.com>2012-05-14 13:08:27 +0200
commit64338258917cdfa8723231655c536edaa94a2c23 (patch)
tree518456177678dc27655f47fa5732ea50e2609dd8 /configure.in
parentd87676da2201bca921f319bd7b02ef8853edfa4f (diff)
configure.in: fix --with-solver-and-workdir-root:
PathFormat fails if path does not exist
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 5038c03f46d1..0fb5b2febc66 100644
--- a/configure.in
+++ b/configure.in
@@ -2189,9 +2189,8 @@ if test -n "${with_solver_and_workdir_root}"; then
if ! test -d ${with_solver_and_workdir_root}; then
AC_MSG_ERROR([directory does not exist: ${with_solver_and_workdir_root}])
fi
- SOLARVER=${with_solver_and_workdir_root}/solver
- PathFormat "$SOLARVER"
- SOLARVER="$formatted_path"
+ PathFormat "${with_solver_and_workdir_root}"
+ SOLARVER=${formatted_path}/solver
else
SOLARVER=${SRC_ROOT}/solver
fi
@@ -3380,9 +3379,8 @@ fi
INPATH="${OUTPATH}${PROEXT}"
if test -n "${with_solver_and_workdir_root}"; then
- WORKDIR=${with_solver_and_workdir_root}/workdir/${INPATH}
- PathFormat "$WORKDIR"
- WORKDIR="$formatted_path"
+ PathFormat "${with_solver_and_workdir_root}"
+ WORKDIR=${formatted_path}/workdir/${INPATH}
else
WORKDIR=${SRC_ROOT}/workdir/${INPATH}
fi