summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-05-16 15:45:36 +0200
committerMichael Stahl <mstahl@redhat.com>2012-05-16 23:58:43 +0200
commit0b1e380e02e1b480648d5101d68c7e1e47520bc9 (patch)
treef2a5efd8c54cd2764580246c0ca5e6cbdef27b44 /configure.in
parenta7098c77b37106e88cd23c9caaf0d31eaa0d5cba (diff)
try to fix --with-solver-and-workdir-root on Windows
idlc breaks because sal considers X:\\foo an invalid system path
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4c82f393cb0c..9c23d8a84ec8 100644
--- a/configure.in
+++ b/configure.in
@@ -2206,7 +2206,12 @@ if test -n "${with_solver_and_workdir_root}"; then
AC_MSG_ERROR([directory does not exist: ${with_solver_and_workdir_root}])
fi
PathFormat "${with_solver_and_workdir_root}"
- SOLARVER=${formatted_path}/solver
+ # IsValidFilePath in /sal/osl/w32/file_url.cxx rejects "X:\\" breaking idlc
+ if echo ${formatted_path} | $GREP -q '/$'; then
+ SOLARVER=${formatted_path}solver
+ else
+ SOLARVER=${formatted_path}/solver
+ fi
else
SOLARVER=${SRC_ROOT}/solver
fi
@@ -3396,7 +3401,12 @@ fi
INPATH="${OUTPATH}${PROEXT}"
if test -n "${with_solver_and_workdir_root}"; then
PathFormat "${with_solver_and_workdir_root}"
- WORKDIR=${formatted_path}/workdir/${INPATH}
+ # IsValidFilePath in /sal/osl/w32/file_url.cxx rejects "X:\\" breaking idlc
+ if echo ${formatted_path} | $GREP -q '/$'; then
+ WORKDIR=${formatted_path}workdir/${INPATH}
+ else
+ WORKDIR=${formatted_path}/workdir/${INPATH}
+ fi
else
WORKDIR=${SRC_ROOT}/workdir/${INPATH}
fi