summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2011-03-29 16:40:32 +0100
committerCaolán McNamara <caolanm@redhat.com>2011-03-30 15:54:29 +0100
commit29dbc36ce0bcad9169aba9daee62cd57d51f87e7 (patch)
tree7b72f28e4bcf2d5ba641c6f4dc753f30e94374b7 /configure.in
parentd7c0f5493420b379b6b3970aa2de17d7f8bb5125 (diff)
default to system zlib on contemporary unices
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8b7f6b99274d..1a20fdc9d65e 100755
--- a/configure.in
+++ b/configure.in
@@ -3865,9 +3865,22 @@ AC_SUBST(SYSTEM_STDLIBS)
dnl ===================================================================
dnl Check for system zlib
dnl ===================================================================
-if test "$_os" = "Darwin" && test "$with_system_zlib" != "no"; then
- with_system_zlib=yes
+if test "$with_system_zlib" != "no"; then
+ if test "$_os" = "Darwin"; then
+ with_system_zlib=yes
+ elif test "$_os" = "Linux"; then
+ with_system_zlib=yes
+ elif test "$_os" = "FreeBSD"; then
+ with_system_zlib=yes
+ elif test "$_os" = "DragonFly"; then
+ with_system_zlib=yes
+ elif test "$_os" = "NetBSD"; then
+ with_system_zlib=yes
+ elif test "$_os" = "OpenBSD"; then
+ with_system_zlib=yes
+ fi
fi
+
AC_MSG_CHECKING([which zlib to use])
if test -n "$with_system_zlib" -o -n "$with_system_libs" && \
test "$with_system_zlib" != "no"; then