summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <cmc@openoffice.org>2009-11-20 12:10:32 +0000
committerCaolán McNamara <cmc@openoffice.org>2009-11-20 12:10:32 +0000
commit9f1383d99c28a753c30e9ab740b29896af64b9b1 (patch)
treefdc0e604d0d68d815d6bb24138c0413a1b633d5e /configure.in
parent291172672f3b89a644814aa7f30e77360cf07f11 (diff)
cmcfixes67: #i105566#: better upstream-used fix to avoid the libfreebl3.so + libcrypt problem on Fedora
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 5 insertions, 31 deletions
diff --git a/configure.in b/configure.in
index 7333bf5b56a2..e38c866424b7 100644
--- a/configure.in
+++ b/configure.in
@@ -284,9 +284,8 @@ AC_ARG_ENABLE(pam-link,
AC_ARG_ENABLE(crypt-link,
[ --disable-crypt-link disable linking with libcrypt instead of dynamically
open it (needed for ancient GNU/Linux distributions
- without crypt()/libcrypt or distributions which link
- libcrypt against conflicting nss libraries)
-],,)
+ without crypt()/libcrypt)
+],,enable_crypt_link=yes)
AC_ARG_ENABLE(xrender-link,
[ --enable-xrender-link link with libXrender instead of dynamically open it
],,)
@@ -2063,39 +2062,14 @@ AC_SUBST(PAM_LINK)
if test "$_os" = "Linux"; then
AC_MSG_CHECKING([whether to link to libcrypt])
- if test -n "$enable_crypt_link" -a "$enable_crypt_link" == "no"; then
- AC_MSG_RESULT([no, dynamically open it])
- CRYPT_LINK=NO
- elif test -n "$enable_crypt_link" -a "$enable_crypt_link" == "yes"; then
+ if test -n "$enable_crypt_link" -a "$enable_crypt_link" != "no"; then
AC_MSG_RESULT([yes])
CRYPT_LINK=YES
AC_CHECK_LIB(crypt, crypt, [],
[AC_MSG_ERROR(libcrypt not found or functional)], [])
else
- cat >crypttest.c <<_ACEOF
-#include <unistd.h>
-#include <stdlib.h>
-
-int main(void)
-{
- char key[[64]];
- setkey(key);
- return 0;
-}
-_ACEOF
- if ! $CC $CFLAGS $LDFLAGS crypttest.c -o crypttest -lcrypt 2>/dev/null > /dev/null; then
- CRYPT_LINK=NO
- AC_MSG_RESULT([no, dynamically open it])
- elif test "$enable_mozilla" = "yes" -a "$with_system_mozilla" != "yes" && `ldd ./crypttest |$EGREP -q libfreebl`; then
- AC_MSG_RESULT([no, dynamically open it])
- CRYPT_LINK=NO
- AC_MSG_WARN([libcrypt links against nss libraries, disabling --enable-crypt-link, use --enable-crypt-link, to override])
- echo "libcrypt links against nss libraries, disabling --enable-crypt-link, use --enable-crypt-link, to override" >> warn
- else
- AC_MSG_RESULT([yes])
- CRYPT_LINK=YES
- fi
- rm -f crypttest.c crypttest
+ AC_MSG_RESULT([no, dynamically open it])
+ CRYPT_LINK=NO
fi
fi
AC_SUBST(CRYPT_LINK)