summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2012-05-03 14:49:36 +0200
committerAndras Timar <atimar@suse.com>2012-10-13 12:24:31 +0200
commit83cef532a748bd9306f961d9cbf9322fd96f34a2 (patch)
tree91878480285018ab740489031e176ce742631277 /configure.in
parenta300017101d66971d83065d4e95f6b1a47fe99fb (diff)
[mono] mono-installation.diff: add mono support
also move mono_loader.*.uno.so into the mono subpackage where it belongs to Conflicts: bin/distro-install-file-lists solenv/gbuild/extensions/post_AuxTargets.mk Change-Id: I681543edb6a27e16c66badc7e9e11743833f2fe3
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4abaa21f86a7..cb45b778fcf4 100644
--- a/configure.in
+++ b/configure.in
@@ -1588,6 +1588,16 @@ AC_ARG_WITH(help,
To build without help, use --without-help.]))
+AC_ARG_WITH(mono-gac-root,
+ AS_HELP_STRING([--with-mono-gac-root],
+ [Define the root of the mono GAC. It is especially
+ needed if you are using $DESTDIR and want to
+ preinstall the mono DLLs into the GAC.])
+ [
+ Usage: --with-mono-gac-root=/usr/lib
+ ],
+,)
+
AC_ARG_WITH(java,
AS_HELP_STRING([--with-java],
[Specify the name of the Java interpreter command. Typically "java"
@@ -4267,6 +4277,11 @@ if test "$_os" = "Linux"; then
else
AC_MSG_RESULT([no])
fi
+
+ MONO_GAC_ROOT=
+ if test -n "$with_mono_gac_root" -a "$with_mono_gac_root" != "no" ; then
+ MONO_GAC_ROOT=$with_mono_gac_root
+ fi
fi
AC_SUBST(CSC_PATH)
AC_SUBST(CSC)
@@ -4274,6 +4289,7 @@ AC_SUBST(AL)
AC_SUBST(ENABLE_MONO)
AC_SUBST(MONO_CFLAGS)
AC_SUBST(MONO_LIBS)
+AC_SUBST(MONO_GAC_ROOT)
AC_SUBST(ENABLE_MONO_CLIMAKER)
AC_SUBST(MKBUNDLE)