summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2012-04-16 14:07:24 +0200
committerRene Engelhard <rene@debian.org>2012-04-16 14:26:08 +0200
commitbbbe092e29ed1d44bc782d07522db1c5d646f6c5 (patch)
treedf3d02a4fbdd03904a5c6f9885f70002b3d545a9 /configure.in
parent062c8a02b0402e535dea3be0aeaf0c32b1964a03 (diff)
configure.in: fix Qt detection in Debian/Ubuntu multiarch
Signed-off-by: Petr Mladek <pmladek@suse.cz>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 825eddaa3247..ea9dee1ea505 100644
--- a/configure.in
+++ b/configure.in
@@ -7784,6 +7784,7 @@ dnl ===================================================================
KDE4_CFLAGS=""
KDE4_LIBS=""
+QMAKE4="qmake"
MOC4="moc"
KDE_GLIB_CFLAGS=""
KDE_GLIB_LIBS=""
@@ -7853,6 +7854,18 @@ if test "$test_kde4" = "yes" -a "$ENABLE_KDE4" = "TRUE" ; then
AC_MSG_ERROR([Qt4 headers not found. Please specify the root of your Qt4 installation by exporting QT4DIR before running "configure".])
fi
+ dnl Check for qmake
+ AC_PATH_PROG( QMAKEQT4, qmake-qt4, no, [`dirname $qt_lib_dir`/bin:$QT4DIR/bin:$PATH] )
+ QMAKE4="$QMAKEQT4"
+ if test "$QMAKE4" = "no" ; then
+ AC_PATH_PROG( QMAKE4, qmake, no, [`dirname $qt_lib_dir`/bin:$QT4DIR/bin:$PATH] )
+ if test "$QMAKE4" = "no" ; then
+ AC_MSG_ERROR([Qmake not found. Please specify
+the root of your Qt installation by exporting QT4DIR before running "configure".])
+ fi
+ fi
+
+ qt_libdirs="`$QMAKE4 -query QT_INSTALL_LIBS` $qt_libdirs"
AC_MSG_CHECKING([for Qt4 libraries])
qt_lib_dir="no"
for lib_dir in $qt_libdirs ; do