summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2011-12-08 23:21:49 +0100
committerLionel Elie Mamane <lionel@mamane.lu>2011-12-08 23:24:07 +0100
commit331892b21d656a2b382165bca2a9e2cc0a777ca8 (patch)
tree05d864ea60b4f14cb966f50456d78c3ef3d0f05e /configure.in
parent202fca9d1534a500ed84dcd4b1e31355a49c4404 (diff)
Allow Xinerama to sit in another directory than other X libraries
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 1c9a08d965fd..44bb5e9a1b66 100644
--- a/configure.in
+++ b/configure.in
@@ -8523,7 +8523,15 @@ if test "$_os" = "Darwin"; then
XINERAMA_LINK=dynamic
AC_MSG_RESULT([yes])
elif test "$_os" = "Linux" -o "$_os" = "FreeBSD"; then
- if test -e "$XLIB/libXinerama.so" -a -e "$XLIB/libXinerama.a"; then
+ if test "$x_libraries" = "default_x_libraries"; then
+ XINERAMALIB=`$PKG_CONFIG --variable=libdir xinerama`
+ if test "x$XINERAMALIB" = x; then
+ XINERAMALIB="/usr/lib"
+ fi
+ else
+ XINERAMALIB="$x_libraries"
+ fi
+ if test -e "$XINERAMALIB/libXinerama.so" -a -e "$XINERAMALIB/libXinerama.a"; then
# we have both versions, let the user decide but use the dynamic one
# per default
USE_XINERAMA=YES
@@ -8532,11 +8540,11 @@ elif test "$_os" = "Linux" -o "$_os" = "FreeBSD"; then
else
XINERAMA_LINK=static
fi
- elif test -e "$XLIB/libXinerama.so" -a ! -e "$XLIB/libXinerama.a"; then
+ elif test -e "$XINERAMALIB/libXinerama.so" -a ! -e "$XINERAMALIB/libXinerama.a"; then
# we have only the dynamic version
USE_XINERAMA=YES
XINERAMA_LINK=dynamic
- elif test -e "$XLIB/libXinerama.a"; then
+ elif test -e "$XINERAMALIB/libXinerama.a"; then
# static version
if echo $host_cpu | grep -E 'i[[3456]]86' 2>/dev/null >/dev/null; then
USE_XINERAMA=YES
@@ -8554,7 +8562,11 @@ elif test "$_os" = "Linux" -o "$_os" = "FreeBSD"; then
AC_MSG_RESULT([yes, with $XINERAMA_LINK linking])
AC_CHECK_HEADER(X11/extensions/Xinerama.h, [],
[AC_MSG_ERROR(Xinerama header not found.)], [])
- XINERAMA_EXTRA_LIBS="-L$XLIB -lXext"
+ XEXTLIBS=`$PKG_CONFIG --variable=libs xext`
+ if test "x$XEXTLIB" = x; then
+ XEXTLIBS="-L$XLIB -L$XINERAMALIB -lXext"
+ fi
+ XINERAMA_EXTRA_LIBS="$XEXTLIBS"
if test "$_os" = "FreeBSD"; then
XINERAMA_EXTRA_LIBS="$XINERAMA_EXTRA_LIBS -lXt"
fi