summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndras Timar <atimar@suse.com>2011-11-23 15:09:18 +0100
committerAndras Timar <atimar@suse.com>2011-11-23 15:09:50 +0100
commit06fe563b1a9a38b9c0057e90f934435125b89605 (patch)
tree1422dae6c8be5f779808c14f350f7bbb2421e9ed /configure.in
parent7264d2767095150944ff1e6999c71be1dbdc6f83 (diff)
don't enable java extensions without java
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index eebcc78f2230..0d1ca1bec120 100644
--- a/configure.in
+++ b/configure.in
@@ -7565,7 +7565,7 @@ AC_SUBST(COMMONS_LOGGING_JAR)
# scripting provider for BeanShell extension?
AC_MSG_CHECKING([whether to build extension for support of scripts in BeanShell])
-if test "x$enable_ext_scripting_beanshell" = "xyes" -a "x$enable_extension_integration" != "xno"; then
+if test "x$enable_ext_scripting_beanshell" = "xyes" -a "x$enable_extension_integration" != "xno" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
ENABLE_SCRIPTING_BEANSHELL=YES
else
@@ -7577,7 +7577,7 @@ AC_SUBST(ENABLE_SCRIPTING_BEANSHELL)
# scripting provider for JavaScript extension?
AC_MSG_CHECKING([whether to build extension for support of scripts in JavaScript])
-if test "x$enable_ext_scripting_javascript" = "xyes" -a "x$enable_extension_integration" != "xno"; then
+if test "x$enable_ext_scripting_javascript" = "xyes" -a "x$enable_extension_integration" != "xno" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
ENABLE_SCRIPTING_JAVASCRIPT=YES
else
@@ -8196,7 +8196,7 @@ dnl ===================================================================
dnl Test whether to include NLPSolver extension
dnl ===================================================================
AC_MSG_CHECKING([for NLPSolver extension integration])
-if test "x$enable_ext_nlpsolver" = "xyes" -a "x$enable_extension_integration" != "xno"; then
+if test "x$enable_ext_nlpsolver" = "xyes" -a "x$enable_extension_integration" != "xno" -a "x$with_java" != "no"; then
BUILD_TYPE="$BUILD_TYPE NLPSOLVER"
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_NLPSOLVER"
AC_MSG_RESULT([yes])