summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2011-11-30 21:09:43 +0100
committerLionel Elie Mamane <lionel@mamane.lu>2011-11-30 21:10:58 +0100
commit05b53b1b8e500b31bef1db737303725a168379da (patch)
treec5e3caf21c6168faf3bb0d814bcf90c92a30d884 /configure.in
parent5510127e89d6971a219ce3664e4631d6c6dda2b1 (diff)
postgresql-sdbc: review build rules
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index a47725f325a3..e2b9ea3ee1a7 100644
--- a/configure.in
+++ b/configure.in
@@ -5400,7 +5400,7 @@ dnl ===================================================================
dnl Check for PostgreSQL stuff
dnl ===================================================================
-if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
+if test "x$enable_ext_postgresql_sdbc" = "xyes" -a "x$enable_extension_integration" != "xno"; then
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_POSTGRESQL"
AC_MSG_CHECKING([for PostgreSQL prerequisites])
@@ -5412,12 +5412,12 @@ if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
AC_MSG_ERROR([pg_config needed; set PGCONFIG if not in PATH])
fi
POSTGRESQL_INC=-I$(pg_config --includedir)
- POSTGRESQL_LIB="-L$(pg_config --libdir) -lpq"
+ POSTGRESQL_LIB="-L$(pg_config --libdir)"
else
SYSTEM_POSTGRESQL=NO
if test -n "$with_libpq_path"; then
AC_MSG_RESULT([external libpq])
- POSTGRESQL_LIB="-L${with_libpq_path}/lib/ -lpq"
+ POSTGRESQL_LIB="-L${with_libpq_path}/lib/"
POSTGRESQL_INC=-I"${with_libpq_path}/include/"
else
AC_MSG_ERROR([not given. Please specify either --with-system-postgresql or --with-libpq-path])
@@ -5427,8 +5427,8 @@ if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
save_CFLAGS=$CFLAGS
save_CPPFLAGS=$CPPFLAGS
save_LIBS=$LIBS
- CPPFLAGS="${POSTGRESQL_INC}"
- LIBS="${POSTGRESQL_LIB}"
+ CPPFLAGS="${CPPFLAGS} ${POSTGRESQL_INC}"
+ LIBS="${LIBS} ${POSTGRESQL_LIB}"
AC_CHECK_HEADER([libpq-fe.h], [], [AC_MSG_ERROR([libpq-fe.h is needed])], [])
AC_CHECK_LIB(pq, PQconnectdbParams, [],
[AC_MSG_ERROR(libpq not found or too old. Need >= 9.0)], [])