summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorIvo Hinkelmann <ihi@openoffice.org>2010-05-10 15:44:41 +0200
committerIvo Hinkelmann <ihi@openoffice.org>2010-05-10 15:44:41 +0200
commit9d5193baac437479232973205e9e0d8f5ad7a8e7 (patch)
treeb51e504b9f458283b11b16194c107cd77ff44037 /configure.in
parent548b2141d8a12f51e1a427e0d67db6fa95954276 (diff)
parenta05f8e28905b1c5ce6a2de468e83c9472c184328 (diff)
CWS-TOOLING: integrate CWS odfmetadata4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 9ae2a5ef7ab2..928e08275213 100644
--- a/configure.in
+++ b/configure.in
@@ -550,6 +550,9 @@ AC_ARG_WITH(system-lpsolve,
AC_ARG_WITH(system-cppunit,
[ --with-system-cppunit Use cppunit already on system
],,)
+AC_ARG_WITH(system-redland,
+[ --with-system-redland Use redland library already on system
+],,)
AC_ARG_WITH(system-mozilla,
[ --with-system-mozilla Use mozilla already on system. Note that some
components cannot be built against a contemporary
@@ -5017,16 +5020,12 @@ dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
AC_MSG_CHECKING([which redland library to use])
-dnl if test -n "$with_system_redland" -o -n "$with_system_libs" && \
-dnl test "$with_system_redland" != "no"; then
-dnl mst: NOTE: right now we need patches against redland
-dnl so we only enable system redland if explicitly requested
-dnl if next version includes patches, insert version check here
-if test -n "$with_system_redland" && \
+if test -n "$with_system_redland" -o -n "$with_system_libs" && \
test "$with_system_redland" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_REDLAND=YES
- PKG_CHECK_MODULES(REDLAND, redland)
+ dnl versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)
+ PKG_CHECK_MODULES(REDLAND, redland >= 1.0.8)
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE REDLAND"