summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorobo <obo@openoffice.org>2010-07-29 12:58:52 +0200
committerobo <obo@openoffice.org>2010-07-29 12:58:52 +0200
commit44fa62ac789b6a594b1442113504b9e62c54f5ef (patch)
treeee97ed31432856d74153968af18570a6a68370b5 /configure.in
parenta91d9cd8c4324aef2d16ea8a0be46a4d81ad702a (diff)
parent9caf879e9ee09e25adb580a54b50cc79522a5123 (diff)
CWS-TOOLING: integrate CWS avmedia102
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 36 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2d276e9ffde8..943c9d017acd 100644
--- a/configure.in
+++ b/configure.in
@@ -198,6 +198,10 @@ AC_ARG_ENABLE(gtk,
[ --disable-gtk Determines whether to use Gtk+ vclplug on platforms
where Gtk+ is available.
],,enable_gtk=yes)
+AC_ARG_ENABLE(gstreamer,
+[ --disable-gstreamer Determines whether to use the GStreamer media
+ backend on platforms where GStreamer is available.
+],,enable_gstreamer=yes)
AC_ARG_ENABLE(systray,
[ --disable-systray Determines whether to build the systray quickstarter.
],,enable_systray=yes)
@@ -926,6 +930,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
_os=SunOS
AC_PATH_PROG( GNUTAR, gtar,,$PATH:/usr/sfw/bin)
if test -z "$GNUTAR"; then
@@ -960,7 +965,8 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
- _os=Linux
+ test_gstreamer=yes
+ _os=Linux
;;
gnu)
test_cups=no
@@ -970,6 +976,7 @@ case "$build_os" in
test_cups=no
test_cairo=yes
test_freetype=no
+ test_gstreamer=no
_os=WINNT
;;
darwin*) # Mac OS X
@@ -978,6 +985,7 @@ case "$build_os" in
test_cairo=yes
test_randr=no
test_freetype=no
+ test_gstreamer=no
_os=Darwin
if test "$enable_systray" = "yes" && test "$enable_gtk" != "no"; then
AC_MSG_WARN([Disabling gtk-quickstarter - not supported on Mac. Use --disable-systray])
@@ -991,6 +999,7 @@ case "$build_os" in
test_randr=no
test_gtk=no
test_freetype=no
+ test_gstreamer=no
_os=OS2
;;
freebsd*)
@@ -1001,6 +1010,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
OSVERSION="$with_os_version"
@@ -1035,6 +1045,7 @@ case "$build_os" in
test_cups=no
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_CFLAGS="-pthread"
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
@@ -1043,6 +1054,7 @@ case "$build_os" in
test_cups=no
test_randr=no
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_LIBS=-pthread
echo "AIX is an alpha port --- Use at own risk" >> warn
_os=AIX
@@ -5750,6 +5762,29 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
dnl ===================================================================
+dnl Check whether the GStreamer libraries are available.
+dnl ===================================================================
+
+GSTREAMER_CFLAGS=""
+GSTREAMER_LIBS=""
+ENABLE_GSTREAMER=""
+
+if test "$test_gstreamer" = "yes"; then
+ AC_MSG_CHECKING([whether to build the GStreamer media backend])
+ if test "x$enable_gstreamer" != "xno" ; then
+ PKG_CHECK_MODULES( GSTREAMER, gtk+-2.0 >= 2.4 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 ,,AC_MSG_ERROR([requirements to build the GStreamer media backend not met. Use --disable-gstreamer or install the missing packages]))
+ ENABLE_GSTREAMER="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(ENABLE_GSTREAMER)
+AC_SUBST(GSTREAMER_CFLAGS)
+AC_SUBST(GSTREAMER_LIBS)
+
+
+dnl ===================================================================
dnl Check whether the Cairo libraries are available.
dnl ===================================================================