summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorka <kai.ahrens@sun.com>2010-06-09 07:07:59 +0200
committerka <kai.ahrens@sun.com>2010-06-09 07:07:59 +0200
commit326d7e0b6879068be8104b530e9ff4ea34baf7ff (patch)
tree17dbb765c4347f8506d8f6b842aae5454b7393d7 /configure.in
parent0770b2664645eca8a6669bb134ab9a59349ff0b6 (diff)
avmedia101: added GStreamer backend for Unix
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 36 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6b6dabe6571b..e75c2ec6b084 100644
--- a/configure.in
+++ b/configure.in
@@ -198,6 +198,10 @@ AC_ARG_ENABLE(gtk,
[ --disable-gtk Determines whether to use Gtk+ vclplug on platforms
where Gtk+ is available.
],,enable_gtk=yes)
+AC_ARG_ENABLE(gstreamer,
+[ --disable-gstreamer Determines whether to use the GStreamer media
+ backend on platforms where GStreamer is available.
+],,enable_gstreamer=yes)
AC_ARG_ENABLE(systray,
[ --disable-systray Determines whether to build the systray quickstarter.
],,enable_systray=yes)
@@ -918,6 +922,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
_os=SunOS
AC_PATH_PROG( GNUTAR, gtar,,$PATH:/usr/sfw/bin)
if test -z "$GNUTAR"; then
@@ -952,7 +957,8 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
- _os=Linux
+ test_gstreamer=yes
+ _os=Linux
;;
gnu)
test_cups=no
@@ -962,6 +968,7 @@ case "$build_os" in
test_cups=no
test_cairo=yes
test_freetype=no
+ test_gstreamer=no
_os=WINNT
;;
darwin*) # Mac OS X
@@ -970,6 +977,7 @@ case "$build_os" in
test_cairo=yes
test_randr=no
test_freetype=no
+ test_gstreamer=no
_os=Darwin
if test "$enable_systray" = "yes" && test "$enable_gtk" != "no"; then
AC_MSG_WARN([Disabling gtk-quickstarter - not supported on Mac. Use --disable-systray])
@@ -983,6 +991,7 @@ case "$build_os" in
test_randr=no
test_gtk=no
test_freetype=no
+ test_gstreamer=no
_os=OS2
;;
freebsd*)
@@ -993,6 +1002,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
OSVERSION="$with_os_version"
@@ -1027,6 +1037,7 @@ case "$build_os" in
test_cups=no
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_CFLAGS="-pthread"
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
@@ -1035,6 +1046,7 @@ case "$build_os" in
test_cups=no
test_randr=no
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_LIBS=-pthread
echo "AIX is an alpha port --- Use at own risk" >> warn
_os=AIX
@@ -5656,6 +5668,29 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
dnl ===================================================================
+dnl Check whether the GStreamer libraries are available.
+dnl ===================================================================
+
+GSTREAMER_CFLAGS=""
+GSTREAMER_LIBS=""
+ENABLE_GSTREAMER=""
+
+if test "$test_gstreamer" = "yes"; then
+ AC_MSG_CHECKING([whether to build the GStreamer media backend])
+ if test "x$enable_gstreamer" != "xno" ; then
+ PKG_CHECK_MODULES( GSTREAMER, gtk+-2.0 >= 2.4 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 ,,AC_MSG_ERROR([requirements to build the GStreamer media backend not met. Use --disable-gstreamer or install the missing packages]))
+ ENABLE_GSTREAMER="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(ENABLE_GSTREAMER)
+AC_SUBST(GSTREAMER_CFLAGS)
+AC_SUBST(GSTREAMER_LIBS)
+
+
+dnl ===================================================================
dnl Check whether the Cairo libraries are available.
dnl ===================================================================