summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@novell.com>2011-08-24 17:53:56 +0300
committerTor Lillqvist <tlillqvist@novell.com>2011-08-24 18:01:49 +0300
commitf25034d53994c6947971cf7c4dd6de0d47d646ce (patch)
tree1e27bb59848aa770c1edd0853c4bdb02decc7774 /configure.in
parente058530153a55ccf83d1f2a4d1ca32b94d83508c (diff)
Disable Mozilla stuff in an --enable-dbgutil build on Windows
The mozab code plays games with _DEBUG (undefining and re-defining it around Mozilla headers), which causes linking error when part of the code has been compiled with _DEBUG and part hasn't. See connectivity/source/drivers/mozab/pre_include_mozilla.h. Just disable Mozilla stuff for now when using --enable-dbgutil.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 77e7bc4a2015..4f949a54f2ac 100755
--- a/configure.in
+++ b/configure.in
@@ -2226,6 +2226,13 @@ if test -n "$enable_dbgutil" && test "$enable_dbgutil" != "no"; then
PRODUCT=""
PROFULLSWITCH=""
AC_MSG_RESULT([yes])
+ if test $_os = WINNT -a \( "$enable_mozilla" = yes -o "$enable_build_mozilla" = yes \); then
+ # We can't build against the Mozilla stuff if using _DEBUG, will get linking errors
+ # See connectivity/drivers/mozab
+ AC_MSG_WARN([Also disabling Mozilla then])
+ enable_mozilla=no
+ enable_build_mozilla=no
+ fi
else
PRODUCT="full"
PROFULLSWITCH="product=full"