summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@novell.com>2011-08-26 20:49:29 +0300
committerTor Lillqvist <tlillqvist@novell.com>2011-08-26 20:54:59 +0300
commiteefc25d1d2eccf04571b8204663d91e61cb5f7f0 (patch)
treed6fe0ed9445a4e059e831742d91f8115fab8663b /configure.in
parent933d898b10f0c71fedc882ac2f2adb258d8b5994 (diff)
Bin USE_MINGW
Its alternative values as used by OOo is irrelevant to us as we don't intend to support building using MinGW on Windows itself. To us, MinGW always means cross-compilation. For us it is enough to look at $(OS)$(COM), and WNTGCC always implies cross-compilation. (OOo on the other hand attempts to support use of the Cygwin gcc with the -mno-cygwin option (which is practically considered an obsolete option), the normal MinGW compiler (but still from Cygwin), but not cros-compilation.)
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index d05200446a32..ded421975527 100755
--- a/configure.in
+++ b/configure.in
@@ -2775,11 +2775,6 @@ if test "$_os" = "WINNT"; then
MACHINE_PREFIX=`$CC -dumpmachine`
if echo $MACHINE_PREFIX | grep -q mingw32; then
AC_MSG_RESULT([yes])
- if $CC -dumpspecs | grep -q "mno-cygwin"; then
- USE_MINGW="cygwin"
- else
- USE_MINGW="pure-mingw"
- fi
else
AC_MSG_ERROR([Compiler is not MinGW.])
fi
@@ -2787,7 +2782,6 @@ if test "$_os" = "WINNT"; then
fi
AC_SUBST(COMEX)
AC_SUBST(MSPDB_PATH)
-AC_SUBST(USE_MINGW)
AC_SUBST(SHOWINCLUDES_PREFIX)
dnl ===================================================================