summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndras Timar <atimar@suse.com>2011-09-01 09:39:11 +0200
committerAndras Timar <atimar@suse.com>2011-09-01 09:39:11 +0200
commitae4ad0eabe36c4df524c99ae4dc509c0bd36c0c6 (patch)
treeedba14be2b44a22899a0bfeca4ab660dffcad49c /configure.in
parent886762160996dfa3fee07cf135e53dfe952ed298 (diff)
extend branding options in configure
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in181
1 files changed, 181 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b2500b20328e..5ca79a5caaa0 100755
--- a/configure.in
+++ b/configure.in
@@ -1220,6 +1220,10 @@ AC_ARG_WITH(lang,
],
,)
+dnl ===================================================================
+dnl Branding
+dnl ===================================================================
+
AC_ARG_WITH(intro-bitmap,
[ --with-intro-bitmap Prefer the specified intro bitmap over the
the default one.
@@ -1227,6 +1231,34 @@ AC_ARG_WITH(intro-bitmap,
Usage: --with-intro-bitmap=/path/my_ooo_intro.png
],,)
+AC_ARG_WITH(intro-progressbar-color,
+[ --with-intro-progressbar-color Set color of progress bar on intro screen.
+ Comma separated RGB values in decimal format.
+
+ Usage: --with-intro-progressbar-color=126,170,23
+],,)
+
+AC_ARG_WITH(intro-progressbar-size,
+[ --with-intro-progressbar-size Set size of progress bar on intro screen.
+ Comma separated values in decimal format.
+
+ Usage: --with-intro-progressbar-size=319,10
+],,)
+
+AC_ARG_WITH(intro-progressbar-position,
+[ --with-intro-progressbar-position Set position of progress bar on intro screen.
+ Comma separated values in decimal format.
+
+ Usage: --with-intro-progressbar-position=164,225
+],,)
+
+AC_ARG_WITH(intro-progressbar-frame-color,
+[ --with-intro-progressbar-frame-color Set color of progress bar frame on intro screen.
+ Comma separated RGB values in decimal format.
+
+ Usage: --with-intro-progressbar-frame-color=207,208,211
+],,)
+
AC_ARG_WITH(about-bitmap,
[ --with-about-bitmap Similarly to --with-intro-bitmap, this allows
specification of bitmap for the About box.
@@ -1234,6 +1266,41 @@ AC_ARG_WITH(about-bitmap,
Usage: --with-about-bitmap=/path/my_ooo_about.png
],,)
+AC_ARG_WITH(startcenter-left-bitmap,
+[ --with-startcenter-left-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the Start center.
+
+ Usage: --with-startcenter-left-bitmap=/path/my_backing_left.png
+],,)
+
+AC_ARG_WITH(startcenter-right-bitmap,
+[ --with-startcenter-right-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the Start center.
+
+ Usage: --with-startcenter-right-bitmap=/path/my_backing_right.png
+],,)
+
+AC_ARG_WITH(startcenter-rtl-left-bitmap,
+[ --with-startcenter-rtl-left-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the Start center.
+
+ Usage: --with-startcenter-rtl-left-bitmap=/path/my_backing_rtl_left.png
+],,)
+
+AC_ARG_WITH(startcenter-rtl-right-bitmap,
+[ --with-startcenter-rtl-right-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the Start center.
+
+ Usage: --with-startcenter-rtl-right-bitmap=/path/my_backing_rtl_right.png
+],,)
+
+AC_ARG_WITH(startcenter-space-bitmap,
+[ --with-startcenter-space-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the Start center.
+
+ Usage: --with-startcenter-space-bitmap=/path/my_backing_space.png
+],,)
+
AC_ARG_WITH(vendor,
AS_HELP_STRING([--with-vendor],
[Set vendor of the build.])
@@ -8878,6 +8945,50 @@ else
fi
AC_SUBST(INTRO_BITMAP)
+AC_MSG_CHECKING([for custom 'intro' progress bar color])
+PROGRESSBARCOLOR=
+if test -z "$with_intro_progressbar_color" ; then
+ PROGRESSBARCOLOR="126,170,23"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSBARCOLOR="$with_intro_progressbar_color"
+ AC_MSG_RESULT([$PROGRESSBARCOLOR])
+fi
+AC_SUBST(PROGRESSBARCOLOR)
+
+AC_MSG_CHECKING([for custom 'intro' progress bar size])
+PROGRESSSIZE=
+if test -z "$with_intro_progressbar_size" ; then
+ PROGRESSSIZE="319,10"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSSIZE="$with_intro_progressbar_size"
+ AC_MSG_RESULT([$PROGRESSSIZE])
+fi
+AC_SUBST(PROGRESSSIZE)
+
+AC_MSG_CHECKING([for custom 'intro' progress bar position])
+PROGRESSPOSITION=
+if test -z "$with_intro_progressbar_position" ; then
+ PROGRESSPOSITION="164,225"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSPOSITION="$with_intro_progressbar_position"
+ AC_MSG_RESULT([$PROGRESSPOSITION])
+fi
+AC_SUBST(PROGRESSPOSITION)
+
+AC_MSG_CHECKING([for custom 'intro' progress bar frame color])
+PROGRESSFRAMECOLOR=
+if test -z "$with_intro_progressbar_frame_color" ; then
+ PROGRESSFRAMECOLOR="207,208,211"
+ AC_MSG_RESULT([none])
+else
+ PROGRESSFRAMECOLOR="$with_intro_progressbar_frame_color"
+ AC_MSG_RESULT([$PROGRESSFRAMECOLOR])
+fi
+AC_SUBST(PROGRESSFRAMECOLOR)
+
AC_MSG_CHECKING([for another 'about' bitmap])
ABOUT_BITMAP=
if test -z "$with_about_bitmap" -o "$with_about_bitmap" = "no" ; then
@@ -8892,6 +9003,76 @@ else
fi
AC_SUBST(ABOUT_BITMAP)
+AC_MSG_CHECKING([for another 'start center left' bitmap])
+STARTCENTER_LEFT_BITMAP=
+if test -z "$with_startcenter_left_bitmap" -o "$with_startcenter_left_bitmap" = "no" ; then
+ STARTCENTER_LEFT_BITMAP=
+ AC_MSG_RESULT([none])
+else
+ case "$with_startcenter_left_bitmap" in
+ *.png) STARTCENTER_LEFT_BITMAP="$with_startcenter_left_bitmap" ;;
+ *) AC_MSG_WARN([Startcenter left bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$STARTCENTER_LEFT_BITMAP])
+fi
+AC_SUBST(STARTCENTER_LEFT_BITMAP)
+
+AC_MSG_CHECKING([for another 'start center right' bitmap])
+STARTCENTER_RIGHT_BITMAP=
+if test -z "$with_startcenter_right_bitmap" -o "$with_startcenter_right_bitmap" = "no" ; then
+ STARTCENTER_RIGHT_BITMAP=
+ AC_MSG_RESULT([none])
+else
+ case "$with_startcenter_right_bitmap" in
+ *.png) STARTCENTER_RIGHT_BITMAP="$with_startcenter_right_bitmap" ;;
+ *) AC_MSG_WARN([Startcenter right bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$STARTCENTER_RIGHT_BITMAP])
+fi
+AC_SUBST(STARTCENTER_RIGHT_BITMAP)
+
+AC_MSG_CHECKING([for another 'start center rtl left' bitmap])
+STARTCENTER_RTL_LEFT_BITMAP=
+if test -z "$with_startcenter_rtl_left_bitmap" -o "$with_startcenter_rtl_left_bitmap" = "no" ; then
+ STARTCENTER_RTL_LEFT_BITMAP=
+ AC_MSG_RESULT([none])
+else
+ case "$with_startcenter_rtl_left_bitmap" in
+ *.png) STARTCENTER_RTL_LEFT_BITMAP="$with_startcenter_rtl_left_bitmap" ;;
+ *) AC_MSG_WARN([Startcenter rtl left bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$STARTCENTER_RTL_LEFT_BITMAP])
+fi
+AC_SUBST(STARTCENTER_RTL_LEFT_BITMAP)
+
+AC_MSG_CHECKING([for another 'start center rtl right' bitmap])
+STARTCENTER_RTL_RIGHT_BITMAP=
+if test -z "$with_startcenter_rtl_right_bitmap" -o "$with_startcenter_rtl_right_bitmap" = "no" ; then
+ STARTCENTER_RTL_RIGHT_BITMAP=
+ AC_MSG_RESULT([none])
+else
+ case "$with_startcenter_rtl_right_bitmap" in
+ *.png) STARTCENTER_RTL_RIGHT_BITMAP="$with_startcenter_rtl_right_bitmap" ;;
+ *) AC_MSG_WARN([Startcenter rtl right bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$STARTCENTER_RTL_RIGHT_BITMAP])
+fi
+AC_SUBST(STARTCENTER_RTL_RIGHT_BITMAP)
+
+AC_MSG_CHECKING([for another 'start center space' bitmap])
+STARTCENTER_SPACE_BITMAP=
+if test -z "$with_startcenter_space_bitmap" -o "$with_startcenter_space_bitmap" = "no" ; then
+ STARTCENTER_SPACE_BITMAP=
+ AC_MSG_RESULT([none])
+else
+ case "$with_startcenter_space_bitmap" in
+ *.png) STARTCENTER_SPACE_BITMAP="$with_startcenter_space_bitmap" ;;
+ *) AC_MSG_WARN([Startcenter left bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$STARTCENTER_SPACE_BITMAP])
+fi
+AC_SUBST(STARTCENTER_SPACE_BITMAP)
+
OOO_VENDOR=
AC_MSG_CHECKING([for vendor])
if test -z "$with_vendor" -o "$with_vendor" = "no" ; then